summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-11-09 23:01:45 +0000
committerjoey <joey>1999-11-09 23:01:45 +0000
commitc104d85de0a15fdccb056ceee32351dd91822237 (patch)
tree6f7eb98f6a55d09b88b266bbe6734f6db38e7b9c
parent9b0b1ba0463f46e7d9ea74cd3cd8fd77ca492e2e (diff)
r306: * Corrected slash substitution problem in dh_installwm.
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdh_installwm31
3 files changed, 23 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog
index dde4b910..fdb9c553 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.0.72) unstable; urgency=low
+
+ * Corrected slash substitution problem in dh_installwm.
+
+ -- Joey Hess <joeyh@master.debian.org> Tue, 9 Nov 1999 15:00:21 -0800
+
debhelper (2.0.71) unstable; urgency=low
* Oh, the build dependancies include all of debhelper's regular
diff --git a/debian/control b/debian/control
index 98b58871..e9706612 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@master.debian.org>
Build-Depends-Indep: perl5, fileutils (>= 3.16-4), file (>= 3.23-1)
-Standards-Version: 3.0.1.1
+Standards-Version: 3.1.0.0
Package: debhelper
Architecture: all
diff --git a/dh_installwm b/dh_installwm
index be3a1373..b3b9059e 100755
--- a/dh_installwm
+++ b/dh_installwm
@@ -1,21 +1,22 @@
-#!/bin/sh -e
+#!/usr/bin/perl -w
#
# Add to postinst and postrm to register a window manager.
-PATH=debian:$PATH:/usr/lib/debhelper
-. dh_lib
+BEGIN { push @INC, "debian", "/usr/share/debhelper" }
+use Dh_Lib;
+init();
-wm=$1
+$wm=shift;
-if [ -z "$wm" ]; then
- error "No window manager was specified."
-fi
+if ($wm eq '') {
+ error("No window manager filename was specified.");
+}
-for PACKAGE in $DH_DOPACKAGES; do
- TMP=`tmpdir $PACKAGE`
-
- if [ ! "$DH_NOSCRIPTS" ]; then
- autoscript "postinst" "postinst-wm" "s/#WM#/$wm/"
- autoscript "postrm" "postrm-wm" "s/#WM#/$wm/"
- fi
-done
+foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
+# $TMP=tmpdir($PACKAGE);
+
+ if (! $dh{NOSCRIPTS}) {
+ autoscript($PACKAGE,"postinst","postinst-wm","s:#WM#:$wm:");
+ autoscript($PACKAGE,"postrm","postrm-wm","s:#WM#:$wm:");
+ }
+}