summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-14 16:17:09 -0400
committerJoey Hess <joey@kitenet.net>2011-06-14 16:17:09 -0400
commitc64ed6af2930e40666aa3069d4e40a7dcd1bc1dd (patch)
treefe5ae4872f164c86381ccc154a6dd4d5e06e3b47
parent6aca0eba03b03e3c898b132f5a6d005118ed6d4c (diff)
parentcbe68c8579e8abc03aeff939306b2d34cb1fe8ac (diff)
Merge branch 'master' into smarter-targets
Conflicts: debhelper.pod debian/changelog
-rw-r--r--Debian/Debhelper/Buildsystem/autoconf.pm11
-rw-r--r--debhelper.pod5
-rw-r--r--debian/changelog2
3 files changed, 15 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/autoconf.pm b/Debian/Debhelper/Buildsystem/autoconf.pm
index c211d8da..20b9fd44 100644
--- a/Debian/Debhelper/Buildsystem/autoconf.pm
+++ b/Debian/Debhelper/Buildsystem/autoconf.pm
@@ -38,9 +38,14 @@ sub configure {
push @opts, "--sysconfdir=/etc";
push @opts, "--localstatedir=/var";
my $multiarch=dpkg_architecture_value("DEB_HOST_MULTIARCH");
- if (! compat(8) && defined $multiarch) {
- push @opts, "--libdir=\${prefix}/lib/$multiarch";
- push @opts, "--libexecdir=\${prefix}/lib/$multiarch/" . sourcepackage();
+ if (! compat(8)) {
+ if (defined $multiarch) {
+ push @opts, "--libdir=\${prefix}/lib/$multiarch";
+ push @opts, "--libexecdir=\${prefix}/lib/$multiarch";
+ }
+ else {
+ push @opts, "--libexecdir=\${prefix}/lib";
+ }
}
else {
push @opts, "--libexecdir=\${prefix}/lib/" . sourcepackage();
diff --git a/debhelper.pod b/debhelper.pod
index 301f0472..d54bf4e1 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -555,6 +555,11 @@ ${misc:Pre-Depends}
dh supports use of standard targets in debian/rules without needing
to manually define the dependencies between targets there.
+=item -
+
+<dh_auto_configure> does not include the source package name
+in --libexecdir when using autoconf.
+
=back
=back
diff --git a/debian/changelog b/debian/changelog
index a626a3e4..d22e50ea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ debhelper (8.1.7) UNRELEASED; urgency=low
without needing to explicitly tell make the dependencies between
the targets. Closes: #629139
(Thanks, Roger Leigh)
+ * dh_auto_configure: In v9, does not include the source package name
+ in --libexecdir when using autoconf. Closes: #541458
-- Joey Hess <joeyh@debian.org> Sat, 21 May 2011 15:24:19 -0400