summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2014-02-04 13:14:58 -0400
committerJoey Hess <joey@kitenet.net>2014-02-04 13:14:58 -0400
commitc7b1d28e1157c2f14bb3550c41e37bc37a32b70e (patch)
tree3dc02edc2c8ab47cf8c4a717f54324488fab36e6
parentb4ad930ad2d7f9d94e9cc3395e6f000c4094886e (diff)
dh: Reject unknown parameters that are not dashed command-line parameters intended to be passed on to debhelper commands. Closes: #737635
Note that dh build -n foo bar will pass -nfoobar to the debhelper command. I did not try to change that, as it would add significant complication.
-rw-r--r--debian/changelog3
-rwxr-xr-xdh3
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7eb8d616..e0f5deb2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,9 @@ debhelper (9.20131228) UNRELEASED; urgency=medium
versioned per policy. Closes: #676777
* dh_makeshlibs: Defer propigating dpkg-gensymbols error until
all packages have been processed. Closes: #736640
+ * dh: Reject unknown parameters that are not dashed command-line
+ parameters intended to be passed on to debhelper commands.
+ Closes: #737635
-- Joey Hess <joeyh@debian.org> Sat, 25 Jan 2014 15:49:45 -0400
diff --git a/dh b/dh
index faa82b96..f3bd3213 100755
--- a/dh
+++ b/dh
@@ -587,6 +587,9 @@ while (@ARGV_orig) {
$options[$#options].=$opt;
}
}
+ else {
+ error "Unknown parameter: $opt";
+ }
}
# Figure out at what point in the sequence to start for each package.