summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-05-10 17:00:46 +0000
committerjoey <joey>2003-05-10 17:00:46 +0000
commitc852d31331ae45515d690688320c7ef8b63cd68e (patch)
tree5490bc7e4ce0b51a7366efa4e317776e637f85c6
parentd3e154d83f3f5b00122bb7e96b5843801ef1bdbe (diff)
r585: * dh_python: Honour -n flag. Closes: #192804
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_python4
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index df3e13af..004586a1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (4.1.43) unstable; urgency=low
+
+ * dh_python: Honour -n flag. Closes: #192804
+
+ -- Joey Hess <joeyh@debian.org> Sat, 10 May 2003 13:00:12 -0400
+
debhelper (4.1.42) unstable; urgency=medium
* Fix stupid typo in dh_movefiles. Closes: #188833
diff --git a/dh_python b/dh_python
index 5618c52c..1ed44714 100755
--- a/dh_python
+++ b/dh_python
@@ -187,12 +187,12 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
$verdeps{$pyver} |= PY_MODULE if($deps & PY_MODULE);
}
- if ($verdeps{$pyver} & PY_MODULE) {
+ if ($verdeps{$pyver} & PY_MODULE && ! $dh{NOSCRIPTS}) {
autoscript($package,"postinst","postinst-python","s%#PYVER#%$pyver%;s%#DIRLIST#%$pydir%");
$need_prerm = 1;
}
}
- if ($need_prerm) {
+ if ($need_prerm && ! $dh{NOSCRIPTS}) {
autoscript($package,"prerm","prerm-python","s%#PACKAGE#%$package%");
}
}