summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-09-21 19:01:37 +0000
committerjoey <joey>2000-09-21 19:01:37 +0000
commitd12efd0389e854713e677572c11b5c4a2c4bec33 (patch)
tree0867f2db08d6232baab8447ce2f73674a812d8a3
parentd862e7704c86e7cdec8083932821d905a687d0b1 (diff)
r372: * dh_installmanpages: don't install files that start with .#* -- these
are CVS files..
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installmanpages4
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5109994c..19e79f76 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.1.11) unstable; urgency=low
+
+ * dh_installmanpages: don't install files that start with .#* -- these
+ are CVS files..
+
+ -- Joey Hess <joeyh@debian.org> Thu, 21 Sep 2000 11:58:52 -0700
+
debhelper (2.1.10) unstable; urgency=low
* Modified to allow no spaces between control file field name and value
diff --git a/dh_installmanpages b/dh_installmanpages
index aff70b14..e8f00bfe 100755
--- a/dh_installmanpages
+++ b/dh_installmanpages
@@ -17,8 +17,8 @@ sub find_man {
# Does its filename look like a man page?
# .ex files are examples installed by deb-make,
# we don't want those, or .in files, which are
- # from configure.
- if (! (-f $_ && /^.*\.[1-9].*$/ && ! /\.(ex|in)$/)) {
+ # from configure, nor do we want CVS .#* files.
+ if (! (-f $_ && /^.*\.[1-9].*$/ && ! /\.(ex|in)$/) && ! /^\.#/) {
return;
}