summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-03-16 13:55:39 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-03-16 13:55:39 -0400
commitd23bf7e55891938e480d21bca25ebbf57f207a28 (patch)
treebec5bc5e8a7d5ae7d9511e7310d8f2630d768864
parentf81041e6b6a78f997a7b6000bfa373ba828f745b (diff)
releasing version 6.0.9
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_installman2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b673ead..c2fc479a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (6.0.9) unstable; urgency=low
+
+ * dh_installman: Don't recode symlinks. Closes: #471196
+
+ -- Joey Hess <joeyh@debian.org> Sun, 16 Mar 2008 13:53:39 -0400
+
debhelper (6.0.8) unstable; urgency=low
* dh_installman: Convert all man pages in the build directory to utf-8, not
diff --git a/dh_installman b/dh_installman
index 78e82ea2..dbe25dd2 100755
--- a/dh_installman
+++ b/dh_installman
@@ -196,7 +196,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
foreach my $dir (qw{usr/share/man usr/X11R6/man}) {
if (-e "$tmp/$dir") {
find(sub {
- return unless -f $_;
+ return if ! -f $_ || -l $_;
complex_doit "man --recode UTF-8 ./\Q$_\E > \Q$_.new\E";
doit "chmod",644,"$_.new";
doit "mv","-f","$_.new",$_;