summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-12-30 06:32:16 +0000
committerjoey <joey>2000-12-30 06:32:16 +0000
commitd3134ec2ae827f9e56c0c25af2b7494bfc1e36fc (patch)
tree66fca47082cfd41d7c561d23270b902e50c58d6e
parent72252ab47780f7fa165599510f9ce1804b53ba6d (diff)
r405: foo
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_shlibdeps4
-rw-r--r--dh_shlibdeps.110
3 files changed, 18 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 3e7c54e4..1a52490d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (2.2.10) unstable; urgency=low
+
+ * dh_shlibdeps: re-enabled -l flag, it's needed again. Closes: #80560
+
+ -- Joey Hess <joey@kitenet.net> Tue, 26 Dec 2000 22:05:30 -0800
+
debhelper (2.2.9) unstable; urgency=low
* Fixed perl wanring, Closes: #80242
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 0456a2dc..237d92db 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -29,6 +29,10 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (@filelist) {
+ if ($dh{L_PARAMS}) {
+ $ENV{'LD_LIBRARY_PATH'}=$dh{L_PARAMS};
+ verbose_print("LD_LIBRARY_PATH=$dh{L_PARAMS} \\");
+ }
doit("dpkg-shlibdeps","-Tdebian/${EXT}substvars",@{$dh{U_PARAMS}},'-dDepends',@filelist);
}
}
diff --git a/dh_shlibdeps.1 b/dh_shlibdeps.1
index 6ced958c..d09967a9 100644
--- a/dh_shlibdeps.1
+++ b/dh_shlibdeps.1
@@ -3,7 +3,7 @@
dh_shlibdeps \- calculate shared library dependancies
.SH SYNOPSIS
.B dh_shlibdeps
-.I "[debhelper options] [-uparams] [-Xitem] [-- params]"
+.I "[debhelper options] [-ldirectory] [-uparams] [-Xitem] [-- params]"
.SH "DESCRIPTION"
dh_shlibdeps is a debhelper program that is responsible for calculating
shared library dependancies for packages.
@@ -32,7 +32,13 @@ This may be useful in some situations, but use it with caution. This option
may be used more than once to exclude more than one thing.
.TP
.B \-ldirectory
-This option is ignored, for backwards compatability.
+Before
+.BR dpkg-shlibdeps (1)
+is run, LD_LIBRARY_PATH will be set to the specified directory.
+This is useful for multi-binary packages where a library
+is built in one package and another package contains binaries linked
+against said library. Note that the paths used must be absolute or
+dpkg-shlibdeps will become confused.
.SH ENVIRONMENT
See
.BR debhelper (1)