summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-15 01:28:29 +0000
committerjoey <joey>2001-05-15 01:28:29 +0000
commitd7b306162c16a3d261fe6c7420ac484ac3d9f3ea (patch)
treecf81eaf64f1ba6642fa4a0a67872de7f83752275
parent625338331a19fff4be0d0e70f3ea19fbc5630d4e (diff)
r467: * dh_installinfo: doc enchancement, Closes: #97515
* dh_md5sums: don't fail if pwd has spaces in it (must be scraping the bottom of the bug barrel here). Closes: #97404
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_compress2
-rwxr-xr-xdh_installinfo4
-rwxr-xr-xdh_md5sums2
4 files changed, 14 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fc067da6..0158f610 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.0.22) unstable; urgency=low
+
+ * dh_installinfo: doc enchancement, Closes: #97515
+ * dh_md5sums: don't fail if pwd has spaces in it (must be scraping the
+ bottom of the bug barrel here). Closes: #97404
+
+ -- Joey Hess <joeyh@debian.org> Mon, 14 May 2001 21:22:47 -0400
+
debhelper (3.0.21) unstable; urgency=low
* Corrected bashism (echo -e, DAMNIT), in rules file that resulted in a
diff --git a/dh_compress b/dh_compress
index 0795cbbc..c90ce637 100755
--- a/dh_compress
+++ b/dh_compress
@@ -160,7 +160,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("ln","$hardlinks{$_}.gz","$_.gz");
}
- verbose_print("cd $olddir");
+ verbose_print("cd '$olddir'");
chdir($olddir);
# Fix up symlinks that were pointing to the uncompressed files.
diff --git a/dh_installinfo b/dh_installinfo
index 41446fdd..1fde4c53 100755
--- a/dh_installinfo
+++ b/dh_installinfo
@@ -18,6 +18,10 @@ use Debian::Debhelper::Dh_Lib;
dh_installinfo is a debhelper program that is responsible for installing
info files and registering them with install-info.
+It determines some information about the info files by parsing them, in
+particular, it looks at the INFO-DIR-SECTION line to determine what section
+the info file belongs in.
+
Any filenames specified as parameters will be installed into the first
package dh_installinfo is told to act on. By default, this is the first
binary package in debian/control, but if you use -p, -i, or -a flags, it
diff --git a/dh_md5sums b/dh_md5sums
index 51bd54c8..992de40d 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -70,7 +70,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
my $olddir=getcwd();
- complex_doit("cd $tmp >/dev/null ; find * -type f $exclude ! -regex '^DEBIAN/.*' -print0 | xargs -r0 md5sum > DEBIAN/md5sums ; cd $olddir >/dev/null");
+ complex_doit("cd $tmp >/dev/null ; find * -type f $exclude ! -regex '^DEBIAN/.*' -print0 | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {
doit("rm","-f","$tmp/DEBIAN/md5sums");