summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-02-03 21:35:03 +0000
committerjoey <joey>2003-02-03 21:35:03 +0000
commitdb1642cfc79170f94104cfb5f51e1ee498d49bbe (patch)
tree2ea8378ef29c0b8675d155b2b11b489f6fe4670c
parenta68baf307c4cb61605ad117bfff39332a4e41484 (diff)
r571: * Turned dh_undocumented into a no-op, as policy does not want
undocumented.7 links anymore.
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_undocumented95
-rw-r--r--doc/TODO1
3 files changed, 15 insertions, 88 deletions
diff --git a/debian/changelog b/debian/changelog
index 9553319e..2a80e749 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.30) unstable; urgency=low
+
+ * Turned dh_undocumented into a no-op, as policy does not want
+ undocumented.7 links anymore.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 3 Feb 2003 16:34:13 -0500
+
debhelper (4.1.29) unstable; urgency=low
* List binary-common in .PHONY in rules.multi2. Closes: #173278
diff --git a/dh_undocumented b/dh_undocumented
index 7d98b207..5bce840f 100755
--- a/dh_undocumented
+++ b/dh_undocumented
@@ -2,7 +2,7 @@
=head1 NAME
-dh_undocumented - make symlinks to undocumented.7.gz man page
+dh_undocumented - obsolete undocumented.7 symlink program
=cut
@@ -11,100 +11,19 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_undocumented> [S<I<debhelper options>>] [B<-A>] [S<I<manpage ...>>]
+Do not run!
=head1 DESCRIPTION
-dh_undocumented is a debhelper program that is responsible for making
-symlinks to L<undocumented(7)> for man pages that are not present in your
-package.
-
-The program takes a list of man pages that should be symlinked to
-L<undocumented(7)>. It examines the extension to see what section the man
-page belongs in. After figuring this out, it generates the necessary
-symlinks.
-
-The lists of man pages that need symlinks can be specified in two ways. Any
-man page names specified as
-parameters will be set up in the first package dh_undocumented is told
-to act on. By default, this is the first binary package in debian/control,
-but if you use -p, -i, or -a flags, it will be the first package specified
-by those flags.
-
-Also, a file named debian/package.undocumented can list other man page
-names to set up.
-
-=head1 OPTIONS
-
-=over 4
-
-=item B<-A>, B<--all>
-
-Install undocumented man page symlinks for any man pages specified by
-command line parameters in ALL packages acted on. I doubt anyone will find
-this useful, it's here for consitency with other debhelper programs.
-
-=item I<manpage ...>
-
-Install undocumented man page symlinks for each of these man pages
-into the first package acted on. (Or in all packages acted on if -A is
-specified.)
-
-=back NOTES
-
-Note that Debian policy prohibits links to L<undocumented(7)> unless the
-package has an open bug report stating that it has no man page. You should
-really just write a man page instead; this program is an easy way out.
+This program used to make symlinks to the undocumented.7 man page for man
+pages not present in a package. Debian policy now frowns on use of the
+undocumented.7 man page, and so this program does nothing, and should not
+be used.
=cut
init();
-
-foreach my $package (@{$dh{DOPACKAGES}}) {
- my $tmp=tmpdir($package);
- my $undocumented=pkgfile($package,"undocumented");
-
- my @undoc;
- if ($undocumented) {
- @undoc=filearray($undocumented);
- }
-
- if (($package eq $dh{FIRSTPACKAGE} || $dh{PARAMS_ALL}) && @ARGV) {
- push @undoc, @ARGV;
- }
-
- foreach my $file (@undoc) {
- $file=~s/.gz$//; # .gz extension is optional in input.
-
- # Determine what directory the file belongs in,
- # /usr/share/man, or /usr/X11R6/man, and how the link to
- # the undocumented.7 man page will look.
- my ($dir, $reldir);
- my ($section)=$file=~m/^.*\.(\d)/;
- if (!$section) {
- error("\"$file\" does not have an extension.");
- }
- if ($section != 7) {
- $dir="usr/share/man/man$section";
- $reldir="../man7/";
- }
- else {
- $dir="usr/share/man/man$section";
- $reldir="";
- }
-
- # If an uncompressed version of the page exists, something
- # is weird.
- if (-e "$tmp/$dir/$file") {
- error("A man page $tmp/$dir/$file exists.");
- }
-
- if (! -d "$tmp/$dir") {
- doit("install","-d","$tmp/$dir");
- }
- doit("ln","-sf","${reldir}undocumented.7.gz","$tmp/$dir/$file.gz");
- }
-}
+warning("This program does nothing and should no longer be used.");
=head1 SEE ALSO
diff --git a/doc/TODO b/doc/TODO
index b31dab89..d8d1190e 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -49,3 +49,4 @@ Deprecated:
* dh_movefiles. I won't hold my breath.
* debconf-mergetemplates support and the debian/template.ll files and the
debconf-utils dependency.
+* dh_undocumented