summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-05-15 14:28:42 +0000
committerjoey <joey>2001-05-15 14:28:42 +0000
commite03b78fce8442511e125cc57922267578d07fa29 (patch)
treeba425688785bd6f8d9ca358840613d88212dfe46
parentabb4a093bd111a1f01d73eb2e84c015830d04f1f (diff)
r469: * Missing semi-colon.
* Call dh_shlibdeps as part of build process, as simple guard against this (dh_* should be called, really).
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules1
-rwxr-xr-xdh_shlibdeps2
3 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2d6115fb..70175695 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (3.0.24) unstable; urgency=low
+
+ * Missing semi-colon.
+ * Call dh_shlibdeps as part of build process, as simple guard against
+ this (dh_* should be called, really).
+
+ -- Joey Hess <joeyh@debian.org> Tue, 15 May 2001 10:27:34 -0400
+
debhelper (3.0.23) unstable; urgency=low
* dh_shlibdeps: the -l switch now just adds to LD_LIBRARY_PATH, if it is
diff --git a/debian/rules b/debian/rules
index bc83ec50..9ec7d17c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -91,6 +91,7 @@ binary-indep: build
./dh_installman *.1
./dh_installinfo
./dh_installchangelogs
+ ./dh_shlibdeps
./dh_link
./dh_compress
./dh_fixperms
diff --git a/dh_shlibdeps b/dh_shlibdeps
index ebba4746..274aeeda 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -81,7 +81,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @paths=();
# Add to existing paths, if set.
push @paths, $ENV{'LD_LIBRARY_PATH'}
- if exists $ENV{'LD_LIBRARY_PATH'}
+ if exists $ENV{'LD_LIBRARY_PATH'};
foreach (split(/:/, $dh{L_PARAMS})) {
# Force the path absolute.
if (m:^/:) {