summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-01-03 20:21:40 +0000
committerjoey <joey>2005-01-03 20:21:40 +0000
commite1f91000857fbeb6db23824948f36490659b466e (patch)
tree7398c82bd857ca742658c6cbe47916b553566d6a
parent064fa7f4c5491bca6fd5be266168fde9a67c5789 (diff)
r1735: releasing version 4.2.29
-rw-r--r--debian/changelog5
-rwxr-xr-xdh_installlogcheck32
2 files changed, 20 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index 04ef05f3..d2c66a59 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
-debhelper (4.2.29) UNRELEASED; urgency=low
+debhelper (4.2.29) unstable; urgency=low
* dh_installdocs Spanish manpage update
+ * dh_installlogcheck: change permissions of logcheck rulefules from 600 to
+ 644, at request of logcheck maintainer. Closes: #288357
+ * dh_installlogcheck: fix indentation
-- Joey Hess <joeyh@debian.org> Wed, 15 Dec 2004 08:53:37 -0500
diff --git a/dh_installlogcheck b/dh_installlogcheck
index cea81959..634f33ae 100755
--- a/dh_installlogcheck
+++ b/dh_installlogcheck
@@ -29,23 +29,23 @@ debian/package.logcheck.ignore.paranoid are installed if present.
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
- my $tmp=tmpdir($package);
-
- foreach my $type (qw{ignore.d.workstation ignore.d.server
- ignore.d.paranoid cracking.d
- violations.d violations.ignore.d}) {
- my $typenod=$type;
- $typenod=~s/\.d//;
- my $logcheck=pkgfile($package,"logcheck.$typenod");
- if ($logcheck) {
- if (! -d "$tmp/etc/logcheck/$type") {
- doit("install","-o",0,"-g",0,"-d","$tmp/etc/logcheck/$type");
- }
- my $packagenodot=$package; # run-parts..
- $packagenodot=~s/\./_/g;
- doit("install","-m",600,$logcheck,"$tmp/etc/logcheck/$type/$packagenodot");
+ my $tmp=tmpdir($package);
+
+ foreach my $type (qw{ignore.d.workstation ignore.d.server
+ ignore.d.paranoid cracking.d
+ violations.d violations.ignore.d}) {
+ my $typenod=$type;
+ $typenod=~s/\.d//;
+ my $logcheck=pkgfile($package,"logcheck.$typenod");
+ if ($logcheck) {
+ if (! -d "$tmp/etc/logcheck/$type") {
+ doit("install","-o",0,"-g",0,"-d","$tmp/etc/logcheck/$type");
+ }
+ my $packagenodot=$package; # run-parts..
+ $packagenodot=~s/\./_/g;
+ doit("install","-m","0644",$logcheck,"$tmp/etc/logcheck/$type/$packagenodot");
+ }
}
- }
}
=head1 SEE ALSO