summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-03-25 14:09:24 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-03-25 14:09:24 -0400
commite2356719773f7cfb6abe0f49a45486e1f7b0c5e6 (patch)
treecdf9a62b7b4e9628b9c863d806b5bc1723845140
parentd23bf7e55891938e480d21bca25ebbf57f207a28 (diff)
dh_perl: Remove empty directories created by MakeMaker.
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_perl14
-rw-r--r--man/po4a/po/debhelper.pot43
-rw-r--r--man/po4a/po/es.po44
-rw-r--r--man/po4a/po/fr.po44
5 files changed, 96 insertions, 55 deletions
diff --git a/debian/changelog b/debian/changelog
index c2fc479a..6fa6aaaa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (6.0.10) UNRELEASED; urgency=low
+
+ * dh_perl: Remove empty directories created by MakeMaker.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 25 Mar 2008 14:06:51 -0400
+
debhelper (6.0.9) unstable; urgency=low
* dh_installman: Don't recode symlinks. Closes: #471196
diff --git a/dh_perl b/dh_perl
index 7e446b53..fbeee2d9 100755
--- a/dh_perl
+++ b/dh_perl
@@ -2,7 +2,7 @@
=head1 NAME
-dh_perl - calculates perl dependencies
+dh_perl - calculates perl dependencies and cleans up after MakeMaker
=cut
@@ -25,6 +25,9 @@ and will use this information to generate a dependency on perl or
perlapi. The dependency will be substituted into your package's control
file wherever you place the token "${perl:Depends}".
+dh_perl also cleans up empty directories that MakeMaker can generate when
+installing perl modules.
+
=head1 OPTIONS
=over 4
@@ -135,6 +138,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
addsubstvar($package, "perl:Depends", "perlapi-$Config{version}")
if $deps & XS_MODULE;
}
+
+ # MakeMaker always makes lib and share dirs, but typically
+ # only one directory is installed into.
+ foreach my $dir ("$tmp/usr/share/perl5", "$tmp/usr/lib/perl5") {
+ if (-d $dir) {
+ doit("rmdir", "--ignore-fail-on-non-empty", "--parents",
+ "$dir");
+ }
+ }
}
=head1 SEE ALSO
diff --git a/man/po4a/po/debhelper.pot b/man/po4a/po/debhelper.pot
index bf26976d..6ad9b02b 100644
--- a/man/po4a/po/debhelper.pot
+++ b/man/po4a/po/debhelper.pot
@@ -7,7 +7,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2008-03-10 18:31-0400\n"
+"POT-Creation-Date: 2008-03-25 14:08-0400\n"
"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
"Language-Team: LANGUAGE <LL@li.org>\n"
@@ -864,7 +864,7 @@ msgid ""
msgstr ""
# type: =head1
-#: debhelper.pod:478 dh_builddeb:85 dh_clean:106 dh_compress:189 dh_desktop:47 dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111 dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118 dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109 dh_installexamples:103 dh_installinfo:103 dh_installinit:197 dh_installlogcheck:51 dh_installlogrotate:50 dh_installmanpages:197 dh_installman:246 dh_installmenu:80 dh_installmime:85 dh_installmodules:116 dh_installpam:52 dh_install:251 dh_installppp:56 dh_installwm:107 dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222 dh_md5sums:86 dh_movefiles:162 dh_perl:140 dh_python:282 dh_scrollkeeper:76 dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43 dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
+#: debhelper.pod:478 dh_builddeb:85 dh_clean:106 dh_compress:189 dh_desktop:47 dh_fixperms:110 dh_gconf:90 dh_gencontrol:73 dh_installcatalogs:111 dh_installchangelogs:125 dh_installcron:61 dh_installdebconf:118 dh_installdeb:94 dh_installdirs:83 dh_installdocs:237 dh_installemacsen:109 dh_installexamples:103 dh_installinfo:103 dh_installinit:197 dh_installlogcheck:51 dh_installlogrotate:50 dh_installmanpages:197 dh_installman:246 dh_installmenu:80 dh_installmime:85 dh_installmodules:116 dh_installpam:52 dh_install:251 dh_installppp:56 dh_installwm:107 dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222 dh_md5sums:86 dh_movefiles:162 dh_perl:152 dh_python:282 dh_scrollkeeper:76 dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43 dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
msgid "SEE ALSO"
msgstr ""
@@ -889,7 +889,7 @@ msgid "Debhelper web site."
msgstr ""
# type: =head1
-#: debhelper.pod:492 dh_builddeb:91 dh_clean:112 dh_compress:195 dh_desktop:53 dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117 dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124 dh_installdeb:100 dh_installdirs:89 dh_installdocs:243 dh_installemacsen:115 dh_installexamples:109 dh_installinfo:109 dh_installinit:203 dh_installlogcheck:57 dh_installlogrotate:56 dh_installmanpages:203 dh_installman:252 dh_installmenu:88 dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:257 dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229 dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168 dh_perl:146 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230 dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80 dh_undocumented:34 dh_usrlocal:120
+#: debhelper.pod:492 dh_builddeb:91 dh_clean:112 dh_compress:195 dh_desktop:53 dh_fixperms:116 dh_gconf:96 dh_gencontrol:79 dh_installcatalogs:117 dh_installchangelogs:131 dh_installcron:67 dh_installdebconf:124 dh_installdeb:100 dh_installdirs:89 dh_installdocs:243 dh_installemacsen:115 dh_installexamples:109 dh_installinfo:109 dh_installinit:203 dh_installlogcheck:57 dh_installlogrotate:56 dh_installmanpages:203 dh_installman:252 dh_installmenu:88 dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:257 dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229 dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168 dh_perl:158 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230 dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80 dh_undocumented:34 dh_usrlocal:120
msgid "AUTHOR"
msgstr ""
@@ -918,7 +918,7 @@ msgid ""
msgstr ""
# type: =head1
-#: dh_builddeb:21 dh_clean:25 dh_compress:38 dh_fixperms:31 dh_gconf:34 dh_gencontrol:26 dh_installcatalogs:44 dh_installchangelogs:40 dh_installcron:24 dh_installdebconf:50 dh_installdirs:28 dh_installdocs:51 dh_installemacsen:35 dh_installexamples:29 dh_installinfo:37 dh_installinit:33 dh_installlogrotate:22 dh_installmanpages:40 dh_installman:58 dh_installmenu:34 dh_installmime:31 dh_installmodules:39 dh_installpam:24 dh_install:43 dh_installppp:26 dh_installwm:32 dh_link:48 dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:28 dh_python:39 dh_scrollkeeper:32 dh_shlibdeps:26 dh_strip:35 dh_testdir:23 dh_testversion:34 dh_usrlocal:39
+#: dh_builddeb:21 dh_clean:25 dh_compress:38 dh_fixperms:31 dh_gconf:34 dh_gencontrol:26 dh_installcatalogs:44 dh_installchangelogs:40 dh_installcron:24 dh_installdebconf:50 dh_installdirs:28 dh_installdocs:51 dh_installemacsen:35 dh_installexamples:29 dh_installinfo:37 dh_installinit:33 dh_installlogrotate:22 dh_installmanpages:40 dh_installman:58 dh_installmenu:34 dh_installmime:31 dh_installmodules:39 dh_installpam:24 dh_install:43 dh_installppp:26 dh_installwm:32 dh_link:48 dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:31 dh_python:39 dh_scrollkeeper:32 dh_shlibdeps:26 dh_strip:35 dh_testdir:23 dh_testversion:34 dh_usrlocal:39
msgid "OPTIONS"
msgstr ""
@@ -962,12 +962,12 @@ msgid "Pass I<params> to L<dpkg-deb(1)> when it is used to build the package."
msgstr ""
# type: textblock
-#: dh_builddeb:87 dh_clean:108 dh_compress:191 dh_fixperms:112 dh_gconf:92 dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127 dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85 dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105 dh_installinfo:105 dh_installinit:199 dh_installlogcheck:53 dh_installlogrotate:52 dh_installmanpages:199 dh_installman:248 dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:253 dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225 dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164 dh_perl:142 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45 dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
+#: dh_builddeb:87 dh_clean:108 dh_compress:191 dh_fixperms:112 dh_gconf:92 dh_gencontrol:75 dh_installcatalogs:113 dh_installchangelogs:127 dh_installcron:63 dh_installdebconf:120 dh_installdeb:96 dh_installdirs:85 dh_installdocs:239 dh_installemacsen:111 dh_installexamples:105 dh_installinfo:105 dh_installinit:199 dh_installlogcheck:53 dh_installlogrotate:52 dh_installmanpages:199 dh_installman:248 dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:253 dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225 dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164 dh_perl:154 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45 dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
msgid "L<debhelper(7)>"
msgstr ""
# type: textblock
-#: dh_builddeb:89 dh_clean:110 dh_compress:193 dh_desktop:51 dh_fixperms:114 dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65 dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241 dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107 dh_installinit:201 dh_installlogrotate:54 dh_installmanpages:201 dh_installman:250 dh_installmenu:86 dh_installmime:89 dh_installmodules:120 dh_installpam:56 dh_install:255 dh_installppp:60 dh_installwm:111 dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226 dh_md5sums:90 dh_movefiles:166 dh_perl:144 dh_python:286 dh_scrollkeeper:80 dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47 dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
+#: dh_builddeb:89 dh_clean:110 dh_compress:193 dh_desktop:51 dh_fixperms:114 dh_gconf:94 dh_gencontrol:77 dh_installchangelogs:129 dh_installcron:65 dh_installdebconf:122 dh_installdeb:98 dh_installdirs:87 dh_installdocs:241 dh_installemacsen:113 dh_installexamples:107 dh_installinfo:107 dh_installinit:201 dh_installlogrotate:54 dh_installmanpages:201 dh_installman:250 dh_installmenu:86 dh_installmime:89 dh_installmodules:120 dh_installpam:56 dh_install:255 dh_installppp:60 dh_installwm:111 dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226 dh_md5sums:90 dh_movefiles:166 dh_perl:156 dh_python:286 dh_scrollkeeper:80 dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47 dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
msgid "This program is a part of debhelper."
msgstr ""
@@ -1118,7 +1118,7 @@ msgid "Add these files to the list of files to compress."
msgstr ""
# type: =head1
-#: dh_compress:61 dh_perl:58 dh_python:66 dh_strip:74 dh_usrlocal:55
+#: dh_compress:61 dh_perl:61 dh_python:66 dh_strip:74 dh_usrlocal:55
msgid "CONFORMS TO"
msgstr ""
@@ -3372,7 +3372,7 @@ msgstr ""
# type: textblock
#: dh_perl:5
-msgid "dh_perl - calculates perl dependencies"
+msgid "dh_perl - calculates perl dependencies and cleans up after MakeMaker"
msgstr ""
# type: textblock
@@ -3396,13 +3396,20 @@ msgid ""
"place the token \"${perl:Depends}\"."
msgstr ""
+# type: textblock
+#: dh_perl:28
+msgid ""
+"dh_perl also cleans up empty directories that MakeMaker can generate when "
+"installing perl modules."
+msgstr ""
+
# type: =item
-#: dh_perl:32
+#: dh_perl:35
msgid "B<-d>"
msgstr ""
# type: textblock
-#: dh_perl:34
+#: dh_perl:37
msgid ""
"In some specific cases you may want to depend on perl-base rather than the "
"full perl package. If so, you can pass the -d option to make dh_perl "
@@ -3411,7 +3418,7 @@ msgid ""
msgstr ""
# type: textblock
-#: dh_perl:39
+#: dh_perl:42
msgid ""
"Note that this flag may cause no dependency on perl-base to be generated at "
"all. perl-base is Essential, so its dependency can be left out, unless a "
@@ -3419,12 +3426,12 @@ msgid ""
msgstr ""
# type: =item
-#: dh_perl:43
+#: dh_perl:46
msgid "B<-V>"
msgstr ""
# type: textblock
-#: dh_perl:45
+#: dh_perl:48
msgid ""
"By default, scripts and architecture independent modules don't depend on any "
"specific version of perl. The -V option causes the current version of the "
@@ -3432,12 +3439,12 @@ msgid ""
msgstr ""
# type: =item
-#: dh_perl:49
+#: dh_perl:52
msgid "I<library dirs>"
msgstr ""
# type: textblock
-#: dh_perl:51
+#: dh_perl:54
msgid ""
"If your package installs perl modules in non-standard directories, you can "
"make dh_perl check those directories by passing their names on the command "
@@ -3446,17 +3453,17 @@ msgid ""
msgstr ""
# type: textblock
-#: dh_perl:60 dh_strip:76
+#: dh_perl:63 dh_strip:76
msgid "Debian policy, version 3.0.1"
msgstr ""
# type: textblock
-#: dh_perl:62
+#: dh_perl:65
msgid "Perl policy, version 1.18"
msgstr ""
# type: textblock
-#: dh_perl:148
+#: dh_perl:160
msgid "Brendan O'Dea <bod@debian.org>"
msgstr ""
diff --git a/man/po4a/po/es.po b/man/po4a/po/es.po
index 27ff0b4d..302a211e 100644
--- a/man/po4a/po/es.po
+++ b/man/po4a/po/es.po
@@ -5,7 +5,7 @@
msgid ""
msgstr ""
"Project-Id-Version: PACKAGE VERSION\n"
-"POT-Creation-Date: 2008-03-10 18:31-0400\n"
+"POT-Creation-Date: 2008-03-25 14:08-0400\n"
"PO-Revision-Date: 2005-09-18 00:11+0200\n"
"Last-Translator: Rubén Porras Campo <debian-l10n-spanish@lists.debian.org>\n"
"Language-Team: SPANISH <debian-l10n-spanish@lists.debian.org>\n"
@@ -1153,7 +1153,7 @@ msgstr ""
#: dh_installman:246 dh_installmenu:80 dh_installmime:85 dh_installmodules:116
#: dh_installpam:52 dh_install:251 dh_installppp:56 dh_installwm:107
#: dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222
-#: dh_md5sums:86 dh_movefiles:162 dh_perl:140 dh_python:282 dh_scrollkeeper:76
+#: dh_md5sums:86 dh_movefiles:162 dh_perl:152 dh_python:282 dh_scrollkeeper:76
#: dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43
#: dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
msgid "SEE ALSO"
@@ -1190,7 +1190,7 @@ msgstr "Web de Debhelper."
#: dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:257
#: dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229
#: dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168
-#: dh_perl:146 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230
+#: dh_perl:158 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230
#: dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80
#: dh_undocumented:34 dh_usrlocal:120
msgid "AUTHOR"
@@ -1242,7 +1242,7 @@ msgstr ""
#: dh_installinit:33 dh_installlogrotate:22 dh_installmanpages:40
#: dh_installman:58 dh_installmenu:34 dh_installmime:31 dh_installmodules:39
#: dh_installpam:24 dh_install:43 dh_installppp:26 dh_installwm:32 dh_link:48
-#: dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:28 dh_python:39
+#: dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:31 dh_python:39
#: dh_scrollkeeper:32 dh_shlibdeps:26 dh_strip:35 dh_testdir:23
#: dh_testversion:34 dh_usrlocal:39
msgid "OPTIONS"
@@ -1302,7 +1302,7 @@ msgstr "Pasa I<parámetros> a L<dpkg-deb(1)> cuando se construye el paquete."
#: dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:253
#: dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225
#: dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164
-#: dh_perl:142 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45
+#: dh_perl:154 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45
#: dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
msgid "L<debhelper(7)>"
msgstr "L<debhelper(7)>"
@@ -1316,7 +1316,7 @@ msgstr "L<debhelper(7)>"
#: dh_installman:250 dh_installmenu:86 dh_installmime:89 dh_installmodules:120
#: dh_installpam:56 dh_install:255 dh_installppp:60 dh_installwm:111
#: dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226
-#: dh_md5sums:90 dh_movefiles:166 dh_perl:144 dh_python:286 dh_scrollkeeper:80
+#: dh_md5sums:90 dh_movefiles:166 dh_perl:156 dh_python:286 dh_scrollkeeper:80
#: dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47
#: dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
msgid "This program is a part of debhelper."
@@ -1516,7 +1516,7 @@ msgid "Add these files to the list of files to compress."
msgstr "Añade estos ficheros a la lista de ficheros a comprimir."
# type: =head1
-#: dh_compress:61 dh_perl:58 dh_python:66 dh_strip:74 dh_usrlocal:55
+#: dh_compress:61 dh_perl:61 dh_python:66 dh_strip:74 dh_usrlocal:55
msgid "CONFORMS TO"
msgstr "CONFORME A"
@@ -4523,7 +4523,8 @@ msgstr ""
# type: textblock
#: dh_perl:5
-msgid "dh_perl - calculates perl dependencies"
+#, fuzzy
+msgid "dh_perl - calculates perl dependencies and cleans up after MakeMaker"
msgstr "dh_perl - calcula dependencias de perl"
# type: textblock
@@ -4554,13 +4555,20 @@ msgstr ""
"será substituida en el fichero de control de su paquete dondequiera que "
"usted ubique la señal \"${perl:Depends}\"."
+# type: textblock
+#: dh_perl:28
+msgid ""
+"dh_perl also cleans up empty directories that MakeMaker can generate when "
+"installing perl modules."
+msgstr ""
+
# type: =item
-#: dh_perl:32
+#: dh_perl:35
msgid "B<-d>"
msgstr "B<-d>"
# type: textblock
-#: dh_perl:34
+#: dh_perl:37
msgid ""
"In some specific cases you may want to depend on perl-base rather than the "
"full perl package. If so, you can pass the -d option to make dh_perl "
@@ -4574,7 +4582,7 @@ msgstr ""
"incluidos en el sistema base."
# type: textblock
-#: dh_perl:39
+#: dh_perl:42
msgid ""
"Note that this flag may cause no dependency on perl-base to be generated at "
"all. perl-base is Essential, so its dependency can be left out, unless a "
@@ -4585,12 +4593,12 @@ msgstr ""
"puede obviar, a menos que se requiera una dependencia de versiones."
# type: =item
-#: dh_perl:43
+#: dh_perl:46
msgid "B<-V>"
msgstr "B<-V>"
# type: textblock
-#: dh_perl:45
+#: dh_perl:48
msgid ""
"By default, scripts and architecture independent modules don't depend on any "
"specific version of perl. The -V option causes the current version of the "
@@ -4601,12 +4609,12 @@ msgstr ""
"actual del paquete perl (o perl-base con -d) sea especificada."
# type: =item
-#: dh_perl:49
+#: dh_perl:52
msgid "I<library dirs>"
msgstr "I<dirs biblioteca>"
# type: textblock
-#: dh_perl:51
+#: dh_perl:54
msgid ""
"If your package installs perl modules in non-standard directories, you can "
"make dh_perl check those directories by passing their names on the command "
@@ -4618,17 +4626,17 @@ msgstr ""
"vendorlib y vendorarch por omisión."
# type: textblock
-#: dh_perl:60 dh_strip:76
+#: dh_perl:63 dh_strip:76
msgid "Debian policy, version 3.0.1"
msgstr "Normas de Debian, versión 3.0.1"
# type: textblock
-#: dh_perl:62
+#: dh_perl:65
msgid "Perl policy, version 1.18"
msgstr "Normas de Perl, versión 1.18"
# type: textblock
-#: dh_perl:148
+#: dh_perl:160
msgid "Brendan O'Dea <bod@debian.org>"
msgstr "Brendan O'Dea <bod@debian.org>"
diff --git a/man/po4a/po/fr.po b/man/po4a/po/fr.po
index af627a08..69d58a4d 100644
--- a/man/po4a/po/fr.po
+++ b/man/po4a/po/fr.po
@@ -3,7 +3,7 @@
msgid ""
msgstr ""
"Project-Id-Version: debhelper manpages\n"
-"POT-Creation-Date: 2008-03-10 18:31-0400\n"
+"POT-Creation-Date: 2008-03-25 14:08-0400\n"
"PO-Revision-Date: 2006-11-19 20:50+0100\n"
"Last-Translator: Valery Perrin <valery.perrin.debian@free.fr>\n"
"Language-Team: French <debian-l10n-french@lists.debian.org>\n"
@@ -1180,7 +1180,7 @@ msgstr ""
#: dh_installman:246 dh_installmenu:80 dh_installmime:85 dh_installmodules:116
#: dh_installpam:52 dh_install:251 dh_installppp:56 dh_installwm:107
#: dh_installxfonts:86 dh_link:223 dh_listpackages:28 dh_makeshlibs:222
-#: dh_md5sums:86 dh_movefiles:162 dh_perl:140 dh_python:282 dh_scrollkeeper:76
+#: dh_md5sums:86 dh_movefiles:162 dh_perl:152 dh_python:282 dh_scrollkeeper:76
#: dh_shlibdeps:159 dh_strip:224 dh_suidregister:117 dh_testdir:43
#: dh_testroot:26 dh_testversion:74 dh_undocumented:28 dh_usrlocal:114
msgid "SEE ALSO"
@@ -1218,7 +1218,7 @@ msgstr "Le site internet de debhelper."
#: dh_installmime:91 dh_installmodules:122 dh_installpam:58 dh_install:257
#: dh_installppp:62 dh_installwm:113 dh_installxfonts:92 dh_link:229
#: dh_listpackages:34 dh_makeshlibs:228 dh_md5sums:92 dh_movefiles:168
-#: dh_perl:146 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230
+#: dh_perl:158 dh_python:288 dh_scrollkeeper:82 dh_shlibdeps:165 dh_strip:230
#: dh_suidregister:123 dh_testdir:49 dh_testroot:32 dh_testversion:80
#: dh_undocumented:34 dh_usrlocal:120
msgid "AUTHOR"
@@ -1270,7 +1270,7 @@ msgstr ""
#: dh_installinit:33 dh_installlogrotate:22 dh_installmanpages:40
#: dh_installman:58 dh_installmenu:34 dh_installmime:31 dh_installmodules:39
#: dh_installpam:24 dh_install:43 dh_installppp:26 dh_installwm:32 dh_link:48
-#: dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:28 dh_python:39
+#: dh_makeshlibs:28 dh_md5sums:28 dh_movefiles:32 dh_perl:31 dh_python:39
#: dh_scrollkeeper:32 dh_shlibdeps:26 dh_strip:35 dh_testdir:23
#: dh_testversion:34 dh_usrlocal:39
msgid "OPTIONS"
@@ -1331,7 +1331,7 @@ msgstr ""
#: dh_installmime:87 dh_installmodules:118 dh_installpam:54 dh_install:253
#: dh_installppp:58 dh_installwm:109 dh_installxfonts:88 dh_link:225
#: dh_listpackages:30 dh_makeshlibs:224 dh_md5sums:88 dh_movefiles:164
-#: dh_perl:142 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45
+#: dh_perl:154 dh_python:284 dh_strip:226 dh_suidregister:119 dh_testdir:45
#: dh_testroot:28 dh_testversion:76 dh_undocumented:30 dh_usrlocal:116
msgid "L<debhelper(7)>"
msgstr "L<debhelper(7)>"
@@ -1345,7 +1345,7 @@ msgstr "L<debhelper(7)>"
#: dh_installman:250 dh_installmenu:86 dh_installmime:89 dh_installmodules:120
#: dh_installpam:56 dh_install:255 dh_installppp:60 dh_installwm:111
#: dh_installxfonts:90 dh_link:227 dh_listpackages:32 dh_makeshlibs:226
-#: dh_md5sums:90 dh_movefiles:166 dh_perl:144 dh_python:286 dh_scrollkeeper:80
+#: dh_md5sums:90 dh_movefiles:166 dh_perl:156 dh_python:286 dh_scrollkeeper:80
#: dh_shlibdeps:163 dh_strip:228 dh_suidregister:121 dh_testdir:47
#: dh_testroot:30 dh_testversion:78 dh_undocumented:32 dh_usrlocal:118
msgid "This program is a part of debhelper."
@@ -1546,7 +1546,7 @@ msgid "Add these files to the list of files to compress."
msgstr "Ajoute ces fichiers à la liste des fichiers à comprimer."
# type: =head1
-#: dh_compress:61 dh_perl:58 dh_python:66 dh_strip:74 dh_usrlocal:55
+#: dh_compress:61 dh_perl:61 dh_python:66 dh_strip:74 dh_usrlocal:55
msgid "CONFORMS TO"
msgstr "CONFORMITÉ"
@@ -4619,7 +4619,8 @@ msgstr ""
# type: textblock
#: dh_perl:5
-msgid "dh_perl - calculates perl dependencies"
+#, fuzzy
+msgid "dh_perl - calculates perl dependencies and cleans up after MakeMaker"
msgstr "dh_perl - détermine les dépendances Perl"
# type: textblock
@@ -4652,13 +4653,20 @@ msgstr ""
"substitution a lieu dans le fichier S<« control »> du paquet, à l'emplacement "
"où est indiqué S<« ${perl:Depends} »>."
+# type: textblock
+#: dh_perl:28
+msgid ""
+"dh_perl also cleans up empty directories that MakeMaker can generate when "
+"installing perl modules."
+msgstr ""
+
# type: =item
-#: dh_perl:32
+#: dh_perl:35
msgid "B<-d>"
msgstr "B<-d>"
# type: textblock
-#: dh_perl:34
+#: dh_perl:37
msgid ""
"In some specific cases you may want to depend on perl-base rather than the "
"full perl package. If so, you can pass the -d option to make dh_perl "
@@ -4672,7 +4680,7 @@ msgstr ""
"le système de base."
# type: textblock
-#: dh_perl:39
+#: dh_perl:42
msgid ""
"Note that this flag may cause no dependency on perl-base to be generated at "
"all. perl-base is Essential, so its dependency can be left out, unless a "
@@ -4683,12 +4691,12 @@ msgstr ""
"peut être omise, à moins qu'une dépendance de version soit nécessaire."
# type: =item
-#: dh_perl:43
+#: dh_perl:46
msgid "B<-V>"
msgstr "B<-V>"
# type: textblock
-#: dh_perl:45
+#: dh_perl:48
msgid ""
"By default, scripts and architecture independent modules don't depend on any "
"specific version of perl. The -V option causes the current version of the "
@@ -4699,12 +4707,12 @@ msgstr ""
"spécifier la version en cours du paquet perl (ou perl-base avec -d)."
# type: =item
-#: dh_perl:49
+#: dh_perl:52
msgid "I<library dirs>"
msgstr "I<bibliothèque répertoires>"
# type: textblock
-#: dh_perl:51
+#: dh_perl:54
msgid ""
"If your package installs perl modules in non-standard directories, you can "
"make dh_perl check those directories by passing their names on the command "
@@ -4716,17 +4724,17 @@ msgstr ""
"les répertoires vendorlib et vendorarch."
# type: textblock
-#: dh_perl:60 dh_strip:76
+#: dh_perl:63 dh_strip:76
msgid "Debian policy, version 3.0.1"
msgstr "Charte Debian, version 3.0.1"
# type: textblock
-#: dh_perl:62
+#: dh_perl:65
msgid "Perl policy, version 1.18"
msgstr "Charte Perl, version 1.18"
# type: textblock
-#: dh_perl:148
+#: dh_perl:160
msgid "Brendan O'Dea <bod@debian.org>"
msgstr "Brendan O'Dea <bod@debian.org>"