summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-02-16 18:48:08 +0000
committerjoey <joey>2005-02-16 18:48:08 +0000
commite7104f4e8c2910cede371012a6d175e8649f2952 (patch)
tree0dbcf78d359fb6f201e30d9c0a22824bb702af2e
parent6792c2a45f9a8fc6f5d8b5d98a0b868899382e1e (diff)
r1740: releasing version 4.2.31
-rw-r--r--Debian/Debhelper/Dh_Lib.pm12
-rw-r--r--debhelper.pod2
-rw-r--r--debian/changelog7
3 files changed, 15 insertions, 6 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index c64f6433..f013dee1 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -13,8 +13,8 @@ use vars qw(@ISA @EXPORT %dh);
@EXPORT=qw(&init &doit &complex_doit &verbose_print &error &warning &tmpdir
&pkgfile &pkgext &pkgfilename &isnative &autoscript &filearray
&filedoublearray &getpackages &basename &dirname &xargs %dh
- &compat &addsubstvar &delsubstvar &excludefile &is_udeb
- &udeb_filename);
+ &compat &addsubstvar &delsubstvar &excludefile &package_arch
+ &is_udeb &udeb_filename);
my $max_compat=4;
@@ -612,6 +612,12 @@ sub getpackages {
return @list;
}
+sub package_arch {
+ my $package=shift;
+
+ return $package_arches{$package} eq 'all' ? "all" : buildarch();
+}
+
sub is_udeb {
my $package=shift;
@@ -621,7 +627,7 @@ sub is_udeb {
sub udeb_filename {
my $package=shift;
- my $filearch=$package_arches{$package} eq 'all' ? "all" : buildarch();
+ my $filearch=package_arch($package);
isnative($package); # side effect
my $version=$dh{VERSION};
$version=~s/^[0-9]+://; # strip any epoch
diff --git a/debhelper.pod b/debhelper.pod
index f389924f..285ec1bd 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -299,7 +299,7 @@ the generated dependancy line in the shlibs file.
=item -
You are encouraged to put the new ${misc:Depends} into debian/control to
-suppliment the ${shlibs:Depends} field.
+supplement the ${shlibs:Depends} field.
=item -
diff --git a/debian/changelog b/debian/changelog
index a07870ab..f42c8256 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,11 @@
-debhelper (4.2.31) UNRELEASED; urgency=low
+debhelper (4.2.31) unstable; urgency=low
* Updated dh_installmime Spanish translation.
+ * Spelling fix. Closes: #293158
+ * Patch from Matthias to split out a package_arch and export it in Dh_Lib.
+ Closes: #295383
- -- Joey Hess <joeyh@debian.org> Thu, 20 Jan 2005 15:22:55 -0500
+ -- Joey Hess <joeyh@debian.org> Wed, 16 Feb 2005 13:47:29 -0500
debhelper (4.2.30) unstable; urgency=low