summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-06-10 19:25:01 +0000
committerjoey <joey>2001-06-10 19:25:01 +0000
commite8b9fc5324e8c645d0c18d165e4b7f7bc94c8242 (patch)
tree38e32dd730eac58a21cbb4e1fd5aff58fe5587ad
parent6cd2268d48bd9ba6ec8dd44b39a52cdbdb069792 (diff)
r477: * Check that update-modules is present before running it, since modutils
is not essential. Closes: #100430
-rw-r--r--autoscripts/postinst-modules2
-rw-r--r--autoscripts/postinst-xaw2
-rw-r--r--autoscripts/postrm-menu-method2
-rw-r--r--autoscripts/postrm-modules4
-rw-r--r--autoscripts/postrm-xaw2
-rw-r--r--debian/changelog7
6 files changed, 14 insertions, 5 deletions
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index a7e7c77d..b25a1c13 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,3 +1,3 @@
-if [ "$1" = "configure" ]; then
+if [ "$1" = "configure" -a -x /sbin/update-modules ]; then
update-modules
fi
diff --git a/autoscripts/postinst-xaw b/autoscripts/postinst-xaw
index 324058f8..035aa269 100644
--- a/autoscripts/postinst-xaw
+++ b/autoscripts/postinst-xaw
@@ -1,5 +1,5 @@
if [ "$1" = "configure" ]; then
- if test -x /usr/sbin/update-xaw-wrappers; then
+ if [ -x /usr/sbin/update-xaw-wrappers ]; then
/usr/sbin/update-xaw-wrappers
fi
for opts in #OPTS#; do
diff --git a/autoscripts/postrm-menu-method b/autoscripts/postrm-menu-method
index 3e63f2f4..2e0faed7 100644
--- a/autoscripts/postrm-menu-method
+++ b/autoscripts/postrm-menu-method
@@ -1,3 +1,3 @@
inst=/etc/menu-methods/#PACKAGE#
if [ "$1" = "remove" -a -f "$inst" ]; then chmod a-x $inst ; fi
-if [ -x /usr/bin/update-menus ] ; then update-menus; fi
+if [ -x /usr/bin/update-menus ]; then update-menus; fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index 7abe0c01..fdf249ef 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1 +1,3 @@
-update-modules
+if [ -x /sbin/update-modules ]; then
+ update-modules
+fi
diff --git a/autoscripts/postrm-xaw b/autoscripts/postrm-xaw
index b8d718ea..14d13ebb 100644
--- a/autoscripts/postrm-xaw
+++ b/autoscripts/postrm-xaw
@@ -1,3 +1,3 @@
-if test -x /usr/sbin/update-xaw-wrappers; then
+if [ -x /usr/sbin/update-xaw-wrappers ]; then
/usr/sbin/update-xaw-wrappers
fi
diff --git a/debian/changelog b/debian/changelog
index edce5fb3..4ca7abea 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.32) unstable; urgency=low
+
+ * Check that update-modules is present before running it, since modutils
+ is not essential. Closes: #100430
+
+ -- Joey Hess <joeyh@debian.org> Sun, 10 Jun 2001 15:13:51 -0400
+
debhelper (3.0.31) unstable; urgency=low
* Remove dh_testversion from example rules file, Closes: #99901