summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Hey <carsten@debian.org>2010-07-18 22:36:11 +0200
committerJoey Hess <joey@kitenet.net>2010-07-18 17:40:19 -0400
commiteb9464fb4bbea788f2703a9bb3314dcd9fe2e0d5 (patch)
tree8969805b774a5072a38036ae49ce6ba604e525c7
parent723ceeff129bc67c32df5db93f828ee4de838b59 (diff)
Bug#589574: [PATCH] dh_fixperms: Ensure files in /etc/sudoers.d/ are mode 440. Closes: #589574
Signed-off-by: Carsten Hey <carsten@debian.org>
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_fixperms7
2 files changed, 13 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 628b0434..c895d780 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.9.4) UNRELEASED; urgency=low
+
+ * dh_fixperms: Ensure files in /etc/sudoers.d/ are mode 440. Closes: #589574
+
+ -- Carsten Hey <carsten@debian.org> Sun, 18 Jul 2010 22:30:06 +0200
+
debhelper (7.9.3) unstable; urgency=low
* perl_makemaker: import compat(). Closes: #587654
diff --git a/dh_fixperms b/dh_fixperms
index 893ca564..65beac6f 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -117,6 +117,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"-type f $find_options -print0",
"2>/dev/null | xargs -0r chmod 644");
}
+
+ # Files in $tmp/etc/sudoers.d/ must be mode 440.
+ if (-d "$tmp/etc/sudoers.d") {
+ complex_doit("find $tmp/etc/sudoers.d",
+ "-type f ! -perm 440 $find_options -print0",
+ "2>/dev/null | xargs -0r chmod 440");
+ }
}
=head1 SEE ALSO