summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2007-12-22 21:03:21 -0500
committerJoey Hess <joey@kitenet.net>2007-12-22 21:03:21 -0500
commited94a7f07c230ad18f01a69f17c81829a57be309 (patch)
tree48998800b6b7c808c5bee62b9b664c6fb71cb776
parent98188af0f226355ecaff2c67d80bea055bdd59a9 (diff)
* dh_installdocs: Tighten doc-base document id parsing to only accept
the characters that the doc-base manual allows in the id. Closes: #445541
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installdocs2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 9bd1dccd..0f6d49ef 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.63) UNRELEASED; urgency=low
+
+ * dh_installdocs: Tighten doc-base document id parsing to only accept
+ the characters that the doc-base manual allows in the id. Closes: #445541
+
+ -- Joey Hess <joeyh@debian.org> Sat, 22 Dec 2007 21:02:11 -0500
+
debhelper (5.0.62) unstable; urgency=low
* Remove execute bit from desktop files in /usr/share/applications.
diff --git a/dh_installdocs b/dh_installdocs
index 61b65996..956a7fb8 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -205,7 +205,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Parse the file to get the doc id.
open (IN, "debian/$fn") || die "Cannot read debian/$fn.";
while (<IN>) {
- if (/^Document:\s+(.*)(\s+)?/) {
+ if (/^Document:\s+([-+.a-z0-9]+)/) {
$doc_ids{$fn}=$1;
last;
}