summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-20 11:49:15 -0400
committerJoey Hess <joey@kitenet.net>2011-06-20 11:49:15 -0400
commitf24df6415586bd07fb5903fba3252495c4e5c065 (patch)
tree21d47990dbf27097425df37dee14c5a996572320
parent031319820566968f4f44f003cd2313062231da46 (diff)
Revert "Always respect DEB_${flag}_{APPEND,SET} envvars."
This reverts commit fcfcd1298f6ea1fcfb2b2b5a529303270aa800d9. Per Raphael's mail.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog4
-rwxr-xr-xdh12
-rwxr-xr-xdh_auto_build5
-rwxr-xr-xdh_auto_configure5
5 files changed, 2 insertions, 26 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 86f729ad..174970b0 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -917,7 +917,7 @@ sub set_buildflags {
$buildflags->load_config();
foreach my $flag ($buildflags->list()) {
next unless $flag =~ /^[A-Z]/; # Skip flags starting with lowercase
- if (! exists $ENV{$flag} || $buildflags->get_origin($flag) eq "env") {
+ if (! exists $ENV{$flag}) {
$ENV{$flag} = $buildflags->get($flag);
}
}
diff --git a/debian/changelog b/debian/changelog
index c20d5b24..57eb40c7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,9 +9,7 @@ debhelper (8.1.7) UNRELEASED; urgency=low
in --libexecdir when using autoconf. Closes: #541458
* dh_auto_build, dh_auto_configure, dh: Set environment variables
listed by dpkg-buildflags --export. Any environment variables that
- are already set to other values will not be changed unless
- appropriate DEB_${flag}_{APPEND,SET} environment variables are also
- set (see dpkg-buildflags(1)).
+ are already set to other values will not be changed.
Closes: #544844
* dh_movefiles: Optimise use of xargs. Closes: #627737
* Correct docs about multiarch and v9. Closes: #630826
diff --git a/dh b/dh
index 5ea6643a..aba8c270 100755
--- a/dh
+++ b/dh
@@ -193,18 +193,6 @@ sequence addons like this:
%:
dh $@ --with quilt
-In order to override standard build flags, export appropriate environment
-variables as documented in the L<dpkg-buildflags(1)> manual page. They will be
-preferred over directly exported their counterparts (CFLAGS, CXXFLAGS, LDFLAGS
-etc.). For example, to append -Wall to the standard CFLAGS and CXXFLAGS, use:
-
- #!/usr/bin/make -f
- export DEB_CFLAGS_APPEND = -Wall
- export DEB_CXXFLAGS_APPEND = -Wall
-
- %:
- dh $@
-
Here is an example of overriding where the B<dh_auto_>I<*> commands find
the package's source, for a package where the source is located in a
subdirectory.
diff --git a/dh_auto_build b/dh_auto_build
index 77b55eef..dccd04a0 100755
--- a/dh_auto_build
+++ b/dh_auto_build
@@ -25,11 +25,6 @@ This is intended to work for about 90% of packages. If it doesn't work,
you're encouraged to skip using B<dh_auto_build> at all, and just run the
build process manually.
-In order to override standard build flags, export appropriate environment
-variables as documented in the L<dpkg-buildflags(1)> manual page. They will be
-preferred over directly exported their counterparts (CFLAGS, CXXFLAGS, LDFLAGS
-etc.).
-
=head1 OPTIONS
See L<debhelper(7)/B<BUILD SYSTEM OPTIONS>> for a list of common build
diff --git a/dh_auto_configure b/dh_auto_configure
index f08c0f6f..daf5ed04 100755
--- a/dh_auto_configure
+++ b/dh_auto_configure
@@ -28,11 +28,6 @@ This is intended to work for about 90% of packages. If it doesn't work,
you're encouraged to skip using B<dh_auto_configure> at all, and just run
F<./configure> or its equivalent manually.
-In order to override standard build flags, export appropriate environment
-variables as documented in the L<dpkg-buildflags(1)> manual page. They will be
-preferred over directly exported their counterparts (CFLAGS, CXXFLAGS, LDFLAGS
-etc.).
-
=head1 OPTIONS
See L<debhelper(7)/B<BUILD SYSTEM OPTIONS>> for a list of common build