summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoeyh <joeyh>2006-05-11 00:19:49 +0000
committerjoeyh <joeyh>2006-05-11 00:19:49 +0000
commitf57a9a0f741a3d249e9b025fab9bb417f0c3e5e6 (patch)
tree8b494e751b4d043861e9041cbec5c31f24858f07
parenta16d0a51903baee3969f277fd0d521ede2652010 (diff)
r1917: * dh_installman: When --language is used, be smarter about stripping
* dh_installxfonts: /etc/X11/fonts/X11R7 is deprecated, back to looking in old location, and not passing --x11r7-layout to update-fonts-alias and update-fonts-scale (but still to update-fonts-dir). Closes: #366234
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installxfonts10
2 files changed, 11 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 9c76e9d3..4ea269ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,13 @@
-debhelper (5.0.35) UNRELEASED; urgency=low
+debhelper (5.0.35) unstable; urgency=low
- * dh_installman: When --language is used, be smarter about stripping
+ * dh_installman: When --language is used, be smarter about stripping
language codes from man page filenames. Only strip things that look like
codes that match the specified languages. Closes: #366645
+ * dh_installxfonts: /etc/X11/fonts/X11R7 is deprecated, back to looking in
+ old location, and not passing --x11r7-layout to update-fonts-alias and
+ update-fonts-scale (but still to update-fonts-dir). Closes: #366234
- -- Joey Hess <joeyh@debian.org> Wed, 10 May 2006 20:07:40 -0400
+ -- Joey Hess <joeyh@debian.org> Wed, 10 May 2006 20:09:00 -0400
debhelper (5.0.34) unstable; urgency=low
diff --git a/dh_installxfonts b/dh_installxfonts
index 655a5f35..d1ced88e 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -22,7 +22,7 @@ and fonts.scale be rebuilt properly at install time.
Before calling this program, you should have installed any X fonts provided
by your package into the appropriate location in the package build
directory, and if you have fonts.alias or fonts.scale files, you should
-install them into the correct location under etc/X11/fonts/X11R7 in your
+install them into the correct location under etc/X11/fonts in your
package build directory.
Your package should depend on xfonts-utils so that the
@@ -62,11 +62,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @cmds;
foreach my $f (@fontdirs) {
# This must come before update-fonts-dir.
- push @cmds, "update-fonts-scale --x11r7-layout $f"
- if -f "$tmp/etc/X11/fonts/X11R7/$f/$package.scale";
+ push @cmds, "update-fonts-scale $f"
+ if -f "$tmp/etc/X11/fonts/$f/$package.scale";
push @cmds, "update-fonts-dir --x11r7-layout $f";
- push @cmds, "update-fonts-alias --x11r7-layout $f"
- if -f "$tmp/etc/X11/fonts/X11R7/$f/$package.alias";
+ push @cmds, "update-fonts-alias $f"
+ if -f "$tmp/etc/X11/fonts/$f/$package.alias";
}
autoscript($package, "postinst", "postinst-xfonts",