summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-06-30 12:48:28 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-06-30 12:48:28 -0400
commitf94b4b1aea929a8af7d093a118a570f8739b9574 (patch)
tree1e52c1302cdd2c4f4d5a62cd7daf419148e04ac0
parentd5872326dc49c2cb7c017748e5f592f53db74cb8 (diff)
dh_install: Handle correctly the case where a glob expands to a dangling symlink, installing the dangling link as requested. Closes: #534565
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_install2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 941331d1..85cdfe89 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (7.2.19) UNRELEASED; urgency=low
+
+ * dh_install: Handle correctly the case where a glob expands to
+ a dangling symlink, installing the dangling link as requested.
+ Closes: #534565
+
+ -- Joey Hess <joeyh@debian.org> Tue, 30 Jun 2009 12:46:22 -0400
+
debhelper (7.2.18) unstable; urgency=low
* dh_shlibdeps: Ensure DEBIAN directory exists, as dpkg-shlibdeps
diff --git a/dh_install b/dh_install
index c83ec81b..3d9a562d 100755
--- a/dh_install
+++ b/dh_install
@@ -147,7 +147,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
my @found = glob "$srcdir/$glob";
if (! compat(6)) {
# Fall back to looking in debian/tmp.
- if (! @found || ! -e $found[0]) {
+ if (! @found || ! (-e $found[0] || -l $found[0])) {
@found = glob "debian/tmp/$glob";
}
}