summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-05-20 21:53:57 +0000
committerjoey <joey>2003-05-20 21:53:57 +0000
commitfbdf58f81f0cbe7cf12fa621ef23deddd9b5c3a3 (patch)
treea96cff718c850f373afd24df91d17516ac2a6d75
parentc852d31331ae45515d690688320c7ef8b63cd68e (diff)
r586: * dh_python: allow for a + at the end of the python version, as in the
python in stable, version 2.1.3+.
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdh_python2
3 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 004586a1..73af2bdf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (4.1.44) unstable; urgency=low
+
+ * dh_python: allow for a + at the end of the python version, as in the
+ python in stable, version 2.1.3+.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 20 May 2003 17:50:16 -0400
+
debhelper (4.1.43) unstable; urgency=low
* dh_python: Honour -n flag. Closes: #192804
diff --git a/debian/control b/debian/control
index 4b4f780c..59ea2bd5 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: devel
Priority: optional
Maintainer: Joey Hess <joeyh@debian.org>
Build-Depends-Indep: perl (>= 5.6.1), coreutils | fileutils (>= 4.0-2.1), file (>= 3.23-1), dpkg-dev (>= 1.9.0)
-Standards-Version: 3.5.9.0
+Standards-Version: 3.5.10.0
Package: debhelper
Architecture: all
diff --git a/dh_python b/dh_python
index 1ed44714..3a001bd4 100755
--- a/dh_python
+++ b/dh_python
@@ -67,7 +67,7 @@ my $python_version = `$python -V 2>&1`;
if ("$python_version" eq "") {
error("Python is not installed, aborting. (Probably forgot to Build-Depend on python.)");
}
-elsif ($python_version =~ m/^Python\s+(\d+)\.(\d+)\.\d+\n$/) {
+elsif ($python_version =~ m/^Python\s+(\d+)\.(\d+)\.\d+\+?\n$/) {
$python_version = "$1.$2" ;
$python_major = $1 ;
} else {