summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-03-17 05:05:04 +0000
committerjoey <joey>2001-03-17 05:05:04 +0000
commitfc94604df8b0551ed52d78f735a65d1f3924ed71 (patch)
tree9e8c896d02974008b7c093aebf87fec9ee19ca43
parent8656127b483fdf64336ee97dc440d6c0a4a5a929 (diff)
r455: * Applied a patch from Anton Zinoviev <anton@lml.bas.bg> to pass -e
to mkfontdir. Closes: #89418
-rw-r--r--autoscripts/postinst-xfonts9
-rw-r--r--autoscripts/postrm-xfonts11
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_installxfonts2
4 files changed, 27 insertions, 2 deletions
diff --git a/autoscripts/postinst-xfonts b/autoscripts/postinst-xfonts
index ae999633..af02e124 100644
--- a/autoscripts/postinst-xfonts
+++ b/autoscripts/postinst-xfonts
@@ -1,3 +1,12 @@
+makefontdir() {
+ ENCDIR=/usr/lib/X11/fonts/encodings
+ if [ -d $ENCDIR -a -d $ENCDIR/large ]; then
+ /usr/bin/X11/mkfontdir -e $ENCDIR -e $ENCDIR/large "$@"
+ else
+ /usr/bin/X11/mkfontdir "$@"
+ fi
+}
+
if [ "$1" = "configure" ]; then
fontdirs="#FONTDIRS#"
updatecmds="#UPDATECMDS#"
diff --git a/autoscripts/postrm-xfonts b/autoscripts/postrm-xfonts
index 016a6392..851b61f5 100644
--- a/autoscripts/postrm-xfonts
+++ b/autoscripts/postrm-xfonts
@@ -1,10 +1,19 @@
+makefontdir() {
+ ENCDIR=/usr/lib/X11/fonts/encodings
+ if [ -d $ENCDIR -a -d $ENCDIR/large ]; then
+ /usr/bin/X11/mkfontdir -e $ENCDIR -e $ENCDIR/large "$@"
+ else
+ /usr/bin/X11/mkfontdir "$@"
+ fi
+}
+
fontdirs="#FONTDIRS#"
updatecmds="#UPDATECMDS#"
for currentdir in $fontdirs; do
longdir=/usr/lib/X11/fonts/$currentdir
if [ -d $longdir ]; then
- for file in fonts.dir fonts.alias; do
+ for file in fonts.dir fonts.alias encodings.dir; do
rm -f $longdir/$file
done
if [ $(find $longdir| wc -l) -eq 1 ]; then
diff --git a/debian/changelog b/debian/changelog
index 062d2c59..6faf5ef5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (3.0.12) unstable; urgency=low
+
+ * Applied a patch from Anton Zinoviev <anton@lml.bas.bg> to pass -e
+ to mkfontdir. Closes: #89418
+
+ -- Joey Hess <joeyh@debian.org> Fri, 16 Mar 2001 21:03:29 -0800
+
debhelper (3.0.11) unstable; urgency=low
* dh_makeshlibs: don't follow links to .so files. Instead, we will look
diff --git a/dh_installxfonts b/dh_installxfonts
index bf0ec0fe..7a50c597 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -48,7 +48,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (@fontdirs) {
# Figure out what commands the postinst will need to call.
- my @updatecmds=('/usr/bin/X11/mkfontdir');
+ my @updatecmds=('makefontdir');
foreach my $f (@fontdirs) {
push @updatecmds, '/usr/sbin/update-fonts-alias'
if -f "$tmp/etc/X11/fonts/$f/$package.alias";