summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-02-16 18:57:06 -0400
committerJoey Hess <joey@kitenet.net>2012-02-21 19:06:35 -0400
commitfcb78ddb4f0ac85f4ba780e7f39b70f2d290f611 (patch)
treedc444a2c63cd0f93b2f02d749739f5edac791132
parent5443176ec72f324f9a025e965aef1bf60c4d7dc3 (diff)
avoid expanding shell variables in sed string
-rw-r--r--Debian/Debhelper/Dh_Lib.pm4
-rw-r--r--debian/changelog2
2 files changed, 4 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index e0a274a4..7073aa4e 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -533,14 +533,14 @@ sub autoscript {
&& !compat(5)) {
# Add fragments to top so they run in reverse order when removing.
complex_doit("echo \"# Automatically added by ".basename($0)."\"> $outfile.new");
- complex_doit("sed \"$sed\" $infile >> $outfile.new");
+ complex_doit("sed '$sed' $infile >> $outfile.new");
complex_doit("echo '# End automatically added section' >> $outfile.new");
complex_doit("cat $outfile >> $outfile.new");
complex_doit("mv $outfile.new $outfile");
}
else {
complex_doit("echo \"# Automatically added by ".basename($0)."\">> $outfile");
- complex_doit("sed \"$sed\" $infile >> $outfile");
+ complex_doit("sed '$sed' $infile >> $outfile");
complex_doit("echo '# End automatically added section' >> $outfile");
}
}
diff --git a/debian/changelog b/debian/changelog
index 13bdc7f5..81ccb07a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ debhelper (9.20120116) UNRELEASED; urgency=low
* dh_auto_install: Set AM_UPDATE_INFO_DIR=no to avoid automake
generating an info dir file. Closes: #634741
* dh_install: Man page clarification. Closes: #659635
+ * Avoid expanding shell metacharacters in sed call in autoscript().
+ Closes: #660794
-- Joey Hess <joeyh@debian.org> Wed, 08 Feb 2012 13:46:13 -0400