summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2000-05-01 20:37:56 +0000
committerjoey <joey>2000-05-01 20:37:56 +0000
commitfd9a5d1c473866b021b703cc06878baa35acdc38 (patch)
treef34bcacddae15d9275cd781081b860c251fc0dda
parent35679ac8f106da17e5f0cdde5bafdda42e13556a (diff)
r348: * Fixes for perl 5.6.
* Spelling fixes.
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_clean10
-rwxr-xr-xdh_gencontrol2
-rwxr-xr-xdh_shlibdeps2
4 files changed, 14 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index dc388f6a..04beb889 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (2.0.95) unstable; urgency=low
+
+ * Fixes for perl 5.6.
+ * Spelling fixes.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 1 May 2000 13:35:11 -0700
+
debhelper (2.0.94) unstable; urgency=low
* examples/rules.multi2: binary-indep and binary-arch targets need to
diff --git a/dh_clean b/dh_clean
index 1f73bea7..1ca10125 100755
--- a/dh_clean
+++ b/dh_clean
@@ -11,11 +11,11 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$EXT=pkgext($PACKAGE);
if (! $dh{D_FLAG}) {
- doit("rm","-f","debian/$EXT\substvars",
- "debian/$EXT\postinst.debhelper",
- "debian/$EXT\postrm.debhelper",
- "debian/$EXT\preinst.debhelper",
- "debian/$EXT\prerm.debhelper");
+ doit("rm","-f","debian/${EXT}substvars",
+ "debian/${EXT}postinst.debhelper",
+ "debian/${EXT}postrm.debhelper",
+ "debian/${EXT}preinst.debhelper",
+ "debian/${EXT}prerm.debhelper");
}
doit ("rm","-rf",$TMP);
diff --git a/dh_gencontrol b/dh_gencontrol
index df53a753..6a12694b 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -20,7 +20,7 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
# Generate and install control file.
doit("dpkg-gencontrol","-l$changelog","-isp","-p$PACKAGE",
- "-Tdebian/$EXT\substvars","-P$TMP",@{$dh{U_PARAMS}});
+ "-Tdebian/${EXT}substvars","-P$TMP",@{$dh{U_PARAMS}});
# This chmod is only necessary if the user sets the umask to something odd.
doit("chmod","644","$TMP/DEBIAN/control");
diff --git a/dh_shlibdeps b/dh_shlibdeps
index 83783aea..4504930b 100755
--- a/dh_shlibdeps
+++ b/dh_shlibdeps
@@ -33,6 +33,6 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
}
if (@filelist) {
- doit("dpkg-shlibdeps","-Tdebian/$EXT\substvars",@{$dh{U_PARAMS}},'-dDepends',@filelist);
+ doit("dpkg-shlibdeps","-Tdebian/${EXT}substvars",@{$dh{U_PARAMS}},'-dDepends',@filelist);
}
}