summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-06-13 16:31:15 -0400
committerJoey Hess <joey@kitenet.net>2011-06-13 16:31:15 -0400
commitff33166782b3d1c8a89d4d844b4259e51e606b5d (patch)
tree772e9b16746aeab8639fa8289424a251bd24d93f
parent6d12631c2e78f48544277660f981272444ca4df0 (diff)
doc updates for recent changes
-rwxr-xr-xdh28
1 files changed, 7 insertions, 21 deletions
diff --git a/dh b/dh
index dcf3b9c6..6ff54f93 100755
--- a/dh
+++ b/dh
@@ -151,16 +151,6 @@ either and instead run your own commands.
override_dh_auto_build:
make universe-explode-in-delight
-If running a configure script, it may be necessary to prevent it being
-run twice, once for architecture-independent packages, and again for
-architecture-dependent packages. This may be accomplished by
-overriding L<dh_autoconfigure(1)>:
-
- override_dh_auto_configure: config.status
-
- config.status:
- dh_auto_configure -- $configure_options
-
Another common case is wanting to do something manually before or
after a particular debhelper command is run.
@@ -250,9 +240,9 @@ L<dh_listpackages(1)> to test what is being built. For example:
endif
Finally, remember that you are not limited to using override targets in the
-rules file when using B<dh>. You can also explicitly define the regular
+rules file when using B<dh>. You can also explicitly define any of the regular
rules file targets when it makes sense to do so. A common reason to do this
-is if your package needs different B<build-arch> and B<build-indep> targets.
+is when your package needs different B<build-arch> and B<build-indep> targets.
For example, a package with a long document build process can put it in
B<build-indep>.
@@ -260,15 +250,15 @@ B<build-indep>.
%:
dh $@
- binary: binary-arch binary-indep ;
- binary-arch:: build-arch
- binary-indep:: build-indep
- build: build-arch build-indep ;
build-indep:
$(MAKE) docs
build-arch:
$(MAKE) bins
+Note that in the example above, dh will arrange for "debian/rules build"
+to call your build-indep and build-arch targets. You do not need to
+explicitly define the dependencies in the rules file when using dh.
+
=head1 INTERNALS
If you're curious about B<dh>'s internals, here's how it works under the hood.
@@ -284,11 +274,7 @@ in the sequence. The B<--until>, B<--before>, B<--after>, and B<--remaining>
options can override this behavior.
A sequence can also run dependent targets in debian/rules. For
-example, the "binary" sequence runs the "install" target. This will
-show up in the dh output as "debian/rules install", but internally
-will be called "rules:install" in the sequence. The "install"
-sequence likewise runs "debian/rules build", internally named
-"rules:build".
+example, the "binary" sequence runs the "install" target.
B<dh> uses the B<DH_INTERNAL_OPTIONS> environment variable to pass information
through to debhelper commands that are run inside override targets. The