summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>1999-10-04 23:35:09 +0000
committerjoey <joey>1999-10-04 23:35:09 +0000
commit03a9c3bed1d03e659e581501b097a1effb9f8277 (patch)
tree0b7bac949a6dbe4e848fe9da039c64655ef6af2a
parent11f6f1e04d23e0a0ad29292996177b3b52ce784e (diff)
r291: * dh_installdocs: if $TMP/usr/share/doc/$PACKAGE is a broken symlink,
leaves it alone, assumming that the maintainer knows what they're doing and is probably linking to the doc dir of another package. (Closes: #46183)
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installdocs5
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a1dbb0f0..344bc542 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (2.0.59) unstable; urgency=low
+
+ * dh_installdocs: if $TMP/usr/share/doc/$PACKAGE is a broken symlink,
+ leaves it alone, assumming that the maintainer knows what they're doing
+ and is probably linking to the doc dir of another package.
+ (Closes: #46183)
+
+ -- Joey Hess <joeyh@master.debian.org> Mon, 4 Oct 1999 16:27:28 -0700
+
debhelper (2.0.58) unstable; urgency=low
* Dh_Lib.pm: fixed bug in xargs() that made boundry words be skipped.
diff --git a/dh_installdocs b/dh_installdocs
index a94a5142..cc5e00a9 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -13,7 +13,10 @@ foreach $PACKAGE (@{$dh{DOPACKAGES}}) {
$TMP=tmpdir($PACKAGE);
$file=pkgfile($PACKAGE,"docs");
- if ( ! -d "$TMP/usr/share/doc/$PACKAGE") {
+ # If this is a dangling symlink, leave it. The maintainer
+ # better know what they're doing.
+ if ( ! -d "$TMP/usr/share/doc/$PACKAGE" &&
+ ! -l "$TMP/usr/share/doc/$PACKAGE") {
doit("install","-d","$TMP/usr/share/doc/$PACKAGE");
}