summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-08-05 13:52:31 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-08-05 13:52:31 -0400
commit06fdabbac03db01b0fdf9ef4856bba2b4b32d80d (patch)
tree7984c1b1ffb91d9af711d2904aa37ba01fe8e7c4
parent299975a38e3c7fb38b216adf21b0f9f46bccbf83 (diff)
perl_build: Fix Build check to honor source directory setting.
-rw-r--r--Debian/Debhelper/Buildsystem/perl_build.pm2
-rw-r--r--debian/changelog6
2 files changed, 7 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_build.pm b/Debian/Debhelper/Buildsystem/perl_build.pm
index 88bcff58..8974be2e 100644
--- a/Debian/Debhelper/Buildsystem/perl_build.pm
+++ b/Debian/Debhelper/Buildsystem/perl_build.pm
@@ -61,7 +61,7 @@ sub install {
sub clean {
my $this=shift;
- if (-f "Build") {
+ if (-e $this->get_sourcepath("Build")) {
$this->do_perl("Build", "--allow_mb_mismatch", 1, "distclean", @_);
}
}
diff --git a/debian/changelog b/debian/changelog
index f5f7487f..3e094e82 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (7.3.11) UNRELEASED; urgency=low
+
+ * perl_build: Fix Build check to honor source directory setting.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 05 Aug 2009 13:52:08 -0400
+
debhelper (7.3.10) unstable; urgency=low
* perl_build: Avoid failing if forced to be used in dh_auto_clean