summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-02-22 19:45:01 +0000
committerjoey <joey>2003-02-22 19:45:01 +0000
commit1331f43bd02122e6368c808e5b69ceefc6e37c53 (patch)
tree5655642d6a92dbe164e081386c97febd1b192f2a
parent91f8bb5fbc5a8cd9d9d64da716f11fcd2831c358 (diff)
r574: * wiggy didn't take my hint about making update-modules send warnings to
stderr, so its overly verbose stdout is now directed to /dev/null to prevent conflicts with debconf. Closes: #150804 * dh_fixperms: only skip examples directories which in a parent of usr/share/doc, not in a deeper tree. Closes: #152602 * dh_compress: stop even looking at usr/doc
-rw-r--r--autoscripts/postinst-modules2
-rw-r--r--autoscripts/postrm-modules2
-rw-r--r--debian/changelog11
-rwxr-xr-xdh_compress2
-rwxr-xr-xdh_fixperms4
5 files changed, 16 insertions, 5 deletions
diff --git a/autoscripts/postinst-modules b/autoscripts/postinst-modules
index bcd7c34b..babf39bd 100644
--- a/autoscripts/postinst-modules
+++ b/autoscripts/postinst-modules
@@ -1,3 +1,3 @@
if [ "$1" = "configure" ] && [ -x /sbin/update-modules ]; then
- update-modules
+ update-modules >/dev/null
fi
diff --git a/autoscripts/postrm-modules b/autoscripts/postrm-modules
index fdf249ef..f2d4cb7a 100644
--- a/autoscripts/postrm-modules
+++ b/autoscripts/postrm-modules
@@ -1,3 +1,3 @@
if [ -x /sbin/update-modules ]; then
- update-modules
+ update-modules >/dev/null
fi
diff --git a/debian/changelog b/debian/changelog
index 3683986d..931467da 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+debhelper (4.1.33) unstable; urgency=low
+
+ * wiggy didn't take my hint about making update-modules send warnings to
+ stderr, so its overly verbose stdout is now directed to /dev/null to
+ prevent conflicts with debconf. Closes: #150804
+ * dh_fixperms: only skip examples directories which in a parent of
+ usr/share/doc, not in a deeper tree. Closes: #152602
+ * dh_compress: stop even looking at usr/doc
+
+ -- Joey Hess <joeyh@debian.org> Sat, 22 Feb 2003 14:45:32 -0500
+
debhelper (4.1.32) unstable; urgency=low
* dh_md5sums: note that it's used by debsums. Closes: #181521
diff --git a/dh_compress b/dh_compress
index eaa17177..de6a97b9 100755
--- a/dh_compress
+++ b/dh_compress
@@ -95,7 +95,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# ".tgz", "-gz", "-z", "_z"
push @files, split(/\n/,`
find usr/info usr/share/info usr/man usr/share/man usr/X11*/man -type f ! -name "*.gz" 2>/dev/null || true;
- find usr/doc usr/share/doc -type f \\( -size +4k -or -name "changelog*" -or -name "NEWS*" \\) \\
+ find usr/share/doc -type f \\( -size +4k -or -name "changelog*" -or -name "NEWS*" \\) \\
\\( -name changelog.html -or ! -iname "*.htm*" \\) \\
! -iname "*.gif" ! -iname "*.png" ! -iname "*.jpg" \\
! -iname "*.jpeg" ! -iname "*.gz" ! -iname "*.taz" \\
diff --git a/dh_fixperms b/dh_fixperms
index 39001a54..d6b0f721 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -59,9 +59,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Fix up premissions in usr/share/doc, setting everything to not
# executable by default, but leave examples directories alone.
- complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type f $find_options ! -regex '.*/examples/.*' -print0 2>/dev/null",
+ complex_doit("find $tmp/usr/share/doc -type f $find_options ! -regex '$tmp/usr/share/doc/[^/]*/examples/.*' -print0 2>/dev/null",
"| xargs -0r chmod 644");
- complex_doit("find $tmp/usr/share/doc $tmp/usr/doc -type d $find_options -print0 2>/dev/null",
+ complex_doit("find $tmp/usr/share/doc -type d $find_options -print0 2>/dev/null",
"| xargs -0r chmod 755");
# Executable man pages are a bad thing..