summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-08-08 15:36:58 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-08-08 15:36:58 -0400
commit16b20dfd69af55f312f21a98d1344252ae179238 (patch)
tree5782b10e2ef55b6cce67f77b7d0dc5dce3a6b209
parent4e9c4c6bb43643a7aab18491c4bf345d91c04d4f (diff)
move comment closer to relevant code
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm7
1 files changed, 4 insertions, 3 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 9cf12e11..4dc2a0d9 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -115,9 +115,6 @@ sub setup_py {
# the requested Python versions.
# Then, run setup.py with each available python, to build
# extensions for each.
- # To allow backports of debhelper we don't pass
- # --install-layout=deb to 'setup.py install` for those Python
- # versions where the option is ignored by distutils/setuptools.
my $python_default = `pyversions -d`;
$python_default =~ s/^\s+//;
@@ -142,6 +139,10 @@ sub setup_py {
foreach my $python (@python_requested, @python_dbg) {
if (-x "/usr/bin/".$python) {
+ # To allow backports of debhelper we don't pass
+ # --install-layout=deb to 'setup.py install` for
+ # those Python versions where the option is
+ # ignored by distutils/setuptools.
if ( $act eq "install" and not
( ($python =~ /^python(?:-dbg)?$/
and $python_default =~ /^python2.[2345]$/)