summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2003-07-07 00:30:40 +0000
committerjoey <joey>2003-07-07 00:30:40 +0000
commit4fa5eb9a9dfdf9fb77dabee86a9eded5f2bc1673 (patch)
tree23b5d0aac85bcb40245f985014cb8d771cbb9ca6
parent8627252ea4d68d0d09381324662a071c358f6066 (diff)
r595: * dh_clean: Clean the *.debhelper temp files on a per-package basis, in
case dh_clean is run on one package at a time. * Removed the debian/substvars removal code entirely. It was only there to deal with half-built trees built with debhelper << 3.0.30
-rw-r--r--debhelper.pod10
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_clean19
-rwxr-xr-xdh_installdeb10
-rwxr-xr-xdh_makeshlibs4
5 files changed, 29 insertions, 23 deletions
diff --git a/debhelper.pod b/debhelper.pod
index 56eb531a..3fa2e2d1 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -47,10 +47,12 @@ be used to configure the behavior of specific debhelper commands. These
files are typically named debian/package.foo (where "package" of course,
is replaced with the package that is being acted on).
-For example,
-dh_installdocs uses files named debian/package.docs to list the documentation
-files it will install. See the man pages of individual commands for details
-about the names and formats of the files they use.
+For example, dh_installdocs uses files named debian/package.docs to list
+the documentation files it will install. See the man pages of individual
+commands for details about the names and formats of the files they use.
+Generally, these files will list files to act on, one file per line. Some
+programs in debhelper use pairs of files and destinations or slightly more
+complicated formats.
Note that if a package is the first (or only) binary package listed in
debian/control, debhelper will use debian/foo if no debian/package.foo
diff --git a/debian/changelog b/debian/changelog
index d424ff91..def6b24e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.1.52) unstable; urgency=low
+
+ * dh_clean: Clean the *.debhelper temp files on a per-package basis, in
+ case dh_clean is run on one package at a time.
+ * Removed the debian/substvars removal code entirely. It was only there to
+ deal with half-built trees built with debhelper << 3.0.30
+
+ -- Joey Hess <joeyh@debian.org> Sun, 6 Jul 2003 20:28:27 -0400
+
debhelper (4.1.51) unstable; urgency=low
* dh_installchangelogs: Install debian/NEWS as NEWS.Debian, even for native
diff --git a/dh_clean b/dh_clean
index a3d8c7be..d4c5943a 100755
--- a/dh_clean
+++ b/dh_clean
@@ -17,9 +17,9 @@ B<dh_clean> [S<I<debhelper options>>] [B<-k>] [B<-d>] [B<-X>I<item>] [S<I<file .
dh_clean is a debhelper program that is responsible for cleaning up after a
package is built. It removes the package build directories, and removes some
-other files, such as debian/substvars, debian/files, and any detritus left
-behind by other debhelper commands (debian/*.debhelper). It also removes
-common files that should not appear in a debian diff:
+other files including debian/files, and any detritus left behind by other
+debhelper commands. It also removes common files that should not appear in a
+debian diff:
#*# *~ DEADJOE *.orig *.rej *.SUMS TAGS core .deps/* *.P
=head1 OPTIONS
@@ -64,6 +64,10 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
if (! $dh{D_FLAG}) {
doit("rm","-f","debian/${ext}substvars")
unless excludefile("debian/${ext}substvars");
+
+ # These are all debhelper temp files, and so it is safe to
+ # wildcard them.
+ complex_doit("rm -f debian/$ext*.debhelper");
}
doit ("rm","-rf",$tmp)
@@ -80,15 +84,6 @@ if (! $dh{D_FLAG}) {
unless excludefile("debian/files");
}
- # These are all debhelper temp files, and so it is safe to
- # wildcard them.
- complex_doit("rm -f debian/*.debhelper");
-
- # Remove some files that were left around by older versions of
- # debhelper.
- doit("rm","-f","debian/substvars")
- unless excludefile("debian/substvars");
-
# See if some files that would normally be deleted are excluded.
my $find_options='';
if (defined($dh{EXCLUDE_FIND}) && $dh{EXCLUDE_FIND} ne '') {
diff --git a/dh_installdeb b/dh_installdeb
index 7c7f8d18..9527ff2e 100755
--- a/dh_installdeb
+++ b/dh_installdeb
@@ -29,11 +29,11 @@ the DEBIAN directory:
package.conffiles
The postinst, preinst, postrm, and prerm are handled specially: If a
-corresponding file named debian/script.debhelper exists, the contents of that
-file are merged into the script as follows: If the script exists, then
-anywhere in it that "#DEBHELPER#" appears, the text of the .debhelper file is
-inserted. If the script does not exist, then a script is generated from
-the .debhelper file. The .debhelper files are created by other debhelper
+corresponding file named debian/package.script.debhelper exists, the contents
+of that file are merged into the script as follows: If the script exists,
+then anywhere in it that "#DEBHELPER#" appears, the text of the .debhelper
+file is inserted. If the script does not exist, then a script is generated
+from the .debhelper file. The .debhelper files are created by other debhelper
programs, such as L<dh_installmenu(1)>, and are shell script fragments.
In V3 compatibility mode and higher, all files in the etc/ directory in a
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 7a4e7b1d..de9f7827 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -57,8 +57,8 @@ Do not modify postinst/postrm scripts.
=item B<-X>I<item>, B<--exclude=>I<item>
-Exclude files that contain "item" anywhere in their filename from
-being treated as shared libraries.
+Exclude files that contain "item" anywhere in their filename or directory
+from being treated as shared libraries.
=back