summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-04-10 12:42:17 -0400
committerJoey Hess <joey@kitenet.net>2012-04-10 12:42:17 -0400
commit561b98cd1572b417d95d7844df797705c330053f (patch)
tree05573ec15f5044d32d2e0db88a07bca6f1f0efb4
parentbe6ed31dcfda103270b09ebce11ff59ccb0a1cc5 (diff)
dh_md5sums: Don't skip DEBIAN directories other than the control files one. Closes: #668276
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_md5sums2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 99286ff8..a2e876b0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ debhelper (9.20120323) UNRELEASED; urgency=low
* Fix a typo. Closes: #665891
* Conflict with too old automake for AM_UPDATE_INFO_DIR=no. Closes: #666901
+ * dh_md5sums: Don't skip DEBIAN directories other than the control files
+ one. Closes: #668276
-- Joey Hess <joeyh@debian.org> Mon, 26 Mar 2012 17:18:58 -0400
diff --git a/dh_md5sums b/dh_md5sums
index a31d7154..4a1264be 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -75,7 +75,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
$exclude.="! \\( $dh{EXCLUDE_FIND} \\) ";
}
- my $find="find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0'";
+ my $find="find . -type f $exclude ! -regex './DEBIAN/.*' -printf '%P\\0'";
complex_doit("(cd $tmp >/dev/null ; $find | LC_ALL=C sort -z | xargs -r0 md5sum > DEBIAN/md5sums) >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {