summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-07-01 00:43:26 +0000
committerjoey <joey>2001-07-01 00:43:26 +0000
commit59d03c4ec32655ace4130ca25f4a3cb51918480e (patch)
tree42a3e24b067fabe50c52672c1fad329aa52795a7
parent208c562558554a18af654ab76544c8f2bcc08096 (diff)
r484: * dh_compress: Don't compress .bz2 files, Closes: #102935
-rw-r--r--debian/changelog6
-rwxr-xr-xdh_compress5
2 files changed, 8 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index e1e61244..d8a8ac55 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debhelper (3.0.39) unstable; urgency=low
+
+ * dh_compress: Don't compress .bz2 files, Closes: #102935
+
+ -- Joey Hess <joeyh@debian.org> Sat, 30 Jun 2001 20:39:17 -0400
+
debhelper (3.0.38) unstable; urgency=low
* fixed doc bog, Closes: #102130
diff --git a/dh_compress b/dh_compress
index c90ce637..203f60c7 100755
--- a/dh_compress
+++ b/dh_compress
@@ -88,8 +88,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
push @files, split(/\n/,`sh $olddir/$compress 2>/dev/null`);
}
else {
- # By default, fall back to what the policy manual says to
- # compress. Note that all the excludes of odd things like _z
+ # Note that all the excludes of odd things like _z
# are because gzip refuses to compress such files, assumming
# they are zip files. I looked at the gzip source to get the
# complete list of such extensions: ".gz", ".z", ".taz",
@@ -99,7 +98,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
find usr/doc usr/share/doc -type f \\( -size +4k -or -name "changelog*" \\) \\
\\( -name changelog.html -or ! -iname "*.htm*" \\) \\
! -iname "*.gif" ! -iname "*.png" ! -iname "*.jpg" ! -iname "*.jpeg" ! -iname "*.gz" \\
- ! -iname "*.taz" ! -iname "*.tgz" ! -iname "*.z" \\
+ ! -iname "*.taz" ! -iname "*.tgz" ! -iname "*.z" ! -iname "*.bz2" \\
! -iname "*-gz" ! -iname "*-z" ! -iname "*_z" \\
! -name "copyright" 2>/dev/null || true
`);