summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2005-04-14 17:37:35 +0000
committerjoey <joey>2005-04-14 17:37:35 +0000
commit5b7ac1ae5b74507930d42c9bbc7c9d52d0b06f89 (patch)
treeb278fe3b7388579fd5723d56f62e9d64ce621362
parentd5453631808c4af4f985f5dacc74b77b68624c30 (diff)
r1747: * dh_md5sums: Don't pass "." to find, so results don't have ./ prepended,
which broke exclusion of conffiles. Thanks, Damir Dzeko (note: this was broken in version 4.1.22)
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_md5sums2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3e23321b..42615897 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,9 @@ debhelper (4.2.33) UNRELEASED; urgency=low
update-modules to indicate /etc/modules.conf is not automatically
generated, we can ignore that return code since it's not a condition that
should fail an installation. Closes: #165400
+ * dh_md5sums: Don't pass "." to find, so results don't have ./ prepended,
+ which broke exclusion of conffiles. Thanks, Damir Dzeko
+ (note: this was broken in version 4.1.22)
-- Joey Hess <joeyh@debian.org> Sat, 9 Apr 2005 17:27:12 -0400
diff --git a/dh_md5sums b/dh_md5sums
index 0619a3ba..91c217e2 100755
--- a/dh_md5sums
+++ b/dh_md5sums
@@ -73,7 +73,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
my $olddir=getcwd();
- complex_doit("cd $tmp >/dev/null ; find . -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
+ complex_doit("cd $tmp >/dev/null ; find -type f $exclude ! -regex '.*/DEBIAN/.*' -printf '%P\\0' | xargs -r0 md5sum > DEBIAN/md5sums ; cd '$olddir' >/dev/null");
# If the file's empty, no reason to waste inodes on it.
if (-z "$tmp/DEBIAN/md5sums") {
doit("rm","-f","$tmp/DEBIAN/md5sums");