summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-05-23 20:11:25 -0400
committerJoey Hess <joey@kitenet.net>2010-05-23 20:11:25 -0400
commit6afb9c4c72cec03a13b1167bc1b7ffea4231066f (patch)
tree5ab4e3fc1f0d26e24ab019535e7e6ff1cafd6027
parent7e7e8bd7cc061dfa3d9d400005e184efa459df2f (diff)
debian/compress files are now deprecated. Seems only one package (genesis) still uses them.
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_compress8
-rw-r--r--doc/TODO4
3 files changed, 8 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index fd0beb53..c851773c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ debhelper (7.4.21) UNRELEASED; urgency=low
not itself normally look will be passed to it, a behavior change which
may break some packages. Closes: #557603
* dh_testversion: Removed this deprecated command.
+ * debian/compress files are now deprecated. Seems only one package
+ (genesis) still uses them.
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/dh_compress b/dh_compress
index 9db01e40..8367b27d 100755
--- a/dh_compress
+++ b/dh_compress
@@ -34,6 +34,8 @@ changelog files. Plus PCF fonts underneath usr/share/fonts/X11/
=item debian/I<package>.compress
+These files are deprecated.
+
If this file exists, the default files are not compressed. Instead, the
file is ran as a shell script, and all filenames that the shell script
outputs will be compressed. The shell script will be run from inside the
@@ -52,8 +54,7 @@ need to.
Exclude files that contain "item" anywhere in their filename from being
compressed. For example, -X.tiff will exclude tiff files from compression.
You may use this option multiple times to build up a list of things to
-exclude. You can accomplish the same thing by using a debian/compress file,
-but this is easier.
+exclude.
=item B<-A>, B<--all>
@@ -91,8 +92,9 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
push @files, @ARGV;
}
if ($compress) {
- # The config file is a sh script that outputs the files to be compressed
+ # The compress file is a sh script that outputs the files to be compressed
# (typically using find).
+ warning("$compress is deprecated; use -X or avoid calling dh_compress instead");
push @files, split(/\n/,`sh $olddir/$compress 2>/dev/null`);
}
else {
diff --git a/doc/TODO b/doc/TODO
index 2af71972..8f6fde37 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -34,10 +34,8 @@ Deprecated:
a string are not used in debhelper itself, but have been left in the
library in case other things use them. Deprecate and remove.
* dh --before , --after , --until , --remaining
+* debian/compress files
Also, grep the entire archive for all dh_* command lines,
and check to see what other switches are not being used, and maybe remove
some of them.
-
-I'd also like to deprecate/remove debian/compress files, -X is
-a better idea.