summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2001-02-09 10:12:44 +0000
committerjoey <joey>2001-02-09 10:12:44 +0000
commit79c6f6e49745da7b25ca3a67c468441a12a7d618 (patch)
tree2417b9109f542b28ef82bc549df529898b383c56
parentad3d82f4a566c40f6992c4e5db795b3c0e9e87c7 (diff)
r427: converting to pod is getting old..
-rwxr-xr-xdh_fixperms2
-rwxr-xr-xdh_gencontrol45
-rw-r--r--dh_gencontrol.138
-rwxr-xr-xdh_installchangelogs75
-rw-r--r--dh_installchangelogs.153
5 files changed, 112 insertions, 101 deletions
diff --git a/dh_fixperms b/dh_fixperms
index 00b122e6..28315c38 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -11,7 +11,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-dh_fixperms [debhelper options] [-Xitem]
+ dh_fixperms [debhelper options] [-Xitem]
=head1 DESCRIPTION
diff --git a/dh_gencontrol b/dh_gencontrol
index e3cfbfe8..0c8c88a2 100755
--- a/dh_gencontrol
+++ b/dh_gencontrol
@@ -1,9 +1,39 @@
#!/usr/bin/perl -w
-#
-# Generate and install the control file. Simple dpkg-gencontrol wrapper.
+
+=head1 NAME
+
+dh_gencontrol - generate and install control file
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_gencontrol [debhelper options] [-uparams] [-- params]
+
+=head1 DESCRIPTION
+
+dh_gencontrol is a debhelper program that is responsible for generating
+control files, and installing them into the DEBIAN directory with the
+proper permissions.
+
+This program is merely a wrapper around L<dpkg-gencontrol(1)>.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-u>I<params>, B<--dpkg-gencontrol-params>I<params>
+=item B<--> I<params>
+
+Pass "params" to L<dpkg-gencontrol(1)>.
+
+=back
+
+=cut
+
init();
foreach my $package (@{$dh{DOPACKAGES}}) {
@@ -29,3 +59,14 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
doit("chown","0.0","$tmp/DEBIAN/control");
}
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_gencontrol.1 b/dh_gencontrol.1
deleted file mode 100644
index 421acd22..00000000
--- a/dh_gencontrol.1
+++ /dev/null
@@ -1,38 +0,0 @@
-.TH DH_GENCONTROL 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_gencontrol \- generate and install control file
-.SH SYNOPSIS
-.B dh_gencontrol
-.I "[debhelper options] [-uparams] [-- params]"
-.SH "DESCRIPTION"
-dh_gencontrol is a debhelper program that is responsible for generating
-control files, and installing them into the DEBIAN directory with the proper
-permissions.
-.P
-This program is merely a wrapper around
-.BR dpkg-gencontrol (1)
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-uparams, \--dpkg-gencontrol-params=params
-.TP
-.B \-\- params
-Pass "params" to
-.BR dpkg-gencontrol (1)
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.TP
-.BR debhelper (1)
-.TP
-.BR dpkg-shlibdeps (1)
-.SH "CONFORMS TO"
-Debian policy, version 3.0.1
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>
diff --git a/dh_installchangelogs b/dh_installchangelogs
index 2a82442b..76dd1c19 100755
--- a/dh_installchangelogs
+++ b/dh_installchangelogs
@@ -1,14 +1,63 @@
#!/usr/bin/perl -w
-#
-# Installs debian/changelog. If another filename is passed to it, installs
-# that file as the upstream changelog.
-#
-# Looks at debian/control to determine if this is a native debian package,
-# if so, the debian changelog is just installed as "changelog", and it is an
-# error to specify an upstream changelog on the command line.
+
+=head1 NAME
+
+dh_installchangelogs - install changelogs into package build directories
+
+=cut
use strict;
use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+ dh_installchangelogs [debhelper options] [-k] [upstream]
+
+=head1 DESCRIPTION
+
+dh_installchangelogs is a debhelper program that is responsible for
+installing changelogs into package build directories.
+
+dh_installchangelogs determines if the package is a debian native package,
+and if so, it installs debian/changelog into usr/share/doc/package/changelog
+in the package build directory. Otherwise, it installs debian/changelog
+into usr/share/doc/package/changelog.Debian in the package build directory. (If
+files named debian/package.changelog exist, they will be used in preference
+to debian/changelog.)
+
+If an upstream changelog file is specified as an option, and the package is
+not a native debian package, then this upstream changelog will be installed
+as usr/share/doc/package/changelog in the package build directory. If the
+changelog is a html file (determined by file extension), it will be
+installed as usr/share/doc/package/changelog.html instead, and will be
+converted to plain text with lynx to generate
+usr/share/doc/package/changelog.
+
+=head1 OPTIONS
+
+=over 4
+
+=item B<-k>, B<--keep>
+
+Keep the original name of the upstream changelog. This will be accomplished
+by installing the upstream changelog as "changelog", and making a symlink from
+that to the original name of the changelog file. This can be useful if the
+upstream changelog has an unusual name, or if other documentation in the
+package refers to the changelog file.
+
+=item I<upstream>
+
+Install this file as the upstream changelog.
+
+=back
+
+=head1 NOTES
+
+It is an error to specify an upstream changelog file for a debian native
+package.
+
+=cut
+
init();
my $upstream=shift;
@@ -66,3 +115,15 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
}
}
+
+=head1 SEE ALSO
+
+L<debhelper(1)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut
diff --git a/dh_installchangelogs.1 b/dh_installchangelogs.1
deleted file mode 100644
index 941b7cfe..00000000
--- a/dh_installchangelogs.1
+++ /dev/null
@@ -1,53 +0,0 @@
-.TH DH_INSTALLCHANGELOGS 1 "" "Debhelper Commands" "Debhelper Commands"
-.SH NAME
-dh_installchangelogs \- install changelogs into package build directories
-.SH SYNOPSIS
-.B dh_installchangelogs
-.I "[debhelper options] [-k] [upstream]"
-.SH "DESCRIPTION"
-dh_installchangelogs is a debhelper program that is responsible for installing
-changelogs into package build directories.
-.P
-dh_installchangelogs determines if the package is a debian native package,
-and if so, it installs debian/changelog into usr/share/doc/package/changelog
-in the package build directory. Otherwise, it installs debian/changelog into
-usr/share/doc/package/changelog.Debian in the package build directory. (If
-files named debian/package.changelog exist, they will be used in preference to
-debian/changelog.)
-.P
-If an upstream changelog file is specified as an option, and the package is
-not a native debian package, then this upstream changelog will be installed
-as usr/share/doc/package/changelog in the package build directory. If the
-changelog is a html file (determined by file extension), it will be
-installed as usr/share/doc/package/changelog.html instead, and will be
-converted to plain text with lynx to generate
-usr/share/doc/package/changelog .
-.SH OPTIONS
-.TP
-.B debhelper options
-See
-.BR debhelper (1)
-for a list of options common to all debhelper commands.
-.TP
-.B \-k, \--keep
-Keep the original name of the upstream changelog. This will be accomplished
-by installing the upstream changelog as "changelog", and making a symlink from
-that to the original name of the changelog file. This can be useful if the
-upstream changelog has an unusual name, or if other documentation in the
-package refers to the changelog file.
-.TP
-.B upstream
-Install this file as the upstream changelog.
-.SH NOTES
-It is an error to specify an upstream changelog file for a debian native
-package.
-.SH ENVIRONMENT
-See
-.BR debhelper (1)
-for a list of environment variables that affect all debhelper commands.
-.SH "SEE ALSO"
-.BR debhelper (1)
-.SH "CONFORMS TO"
-Debian policy, version 3.0.1
-.SH AUTHOR
-Joey Hess <joeyh@debian.org>