summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjoey <joey>2002-10-17 00:41:45 +0000
committerjoey <joey>2002-10-17 00:41:45 +0000
commit79cd10da45b0324c7e8e18c4f7daffbd1d245fab (patch)
treef1ddf71d453dd8a8664a519701063c1cea79f3ff
parentc9bbccaeb003be867ff5c8e8b015da77c9156fc7 (diff)
r558: * Use dpkg-architecture instead of dpkg --print-architecture (again?)
See #164863 * typo fix Closes: #164958 The rest seems clear enough from context, so omitted.
-rw-r--r--Debian/Debhelper/Dh_Lib.pm2
-rw-r--r--debian/changelog9
-rwxr-xr-xdh_installinit2
3 files changed, 11 insertions, 2 deletions
diff --git a/Debian/Debhelper/Dh_Lib.pm b/Debian/Debhelper/Dh_Lib.pm
index 3b7a5192..7770b5ab 100644
--- a/Debian/Debhelper/Dh_Lib.pm
+++ b/Debian/Debhelper/Dh_Lib.pm
@@ -500,7 +500,7 @@ sub excludefile {
sub buildarch {
return $arch if defined $arch;
- $arch=`dpkg --print-architecture` || error($!);
+ $arch=`dpkg-architecture -qDEB_HOST_ARCH 2>/dev/null` || error($!);
chomp $arch;
return $arch;
}
diff --git a/debian/changelog b/debian/changelog
index 792443e6..c11d28c3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+debhelper (4.1.18) unstable; urgency=low
+
+ * Use dpkg-architecture instead of dpkg --print-architecture (again?)
+ See #164863
+ * typo fix Closes: #164958 The rest seems clear enough from context, so
+ omitted.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 16 Oct 2002 20:47:43 -0400
+
debhelper (4.1.17) unstable; urgency=low
* dh_installinit: added --no-start for rcS type scripts. Closes: #136502
diff --git a/dh_installinit b/dh_installinit
index a9070f2d..1eaffc0c 100755
--- a/dh_installinit
+++ b/dh_installinit
@@ -44,7 +44,7 @@ Do not restart init script on upgrade.
=item B<--no-start>
-Do not start the init script at on install or upgrade, or stop it on removal.
+Do not start the init script on install or upgrade, or stop it on removal.
Only call update-rc.d. Useful for rcS scripts.
=item B<-d>, B<--remove-d>