summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-02-27 16:33:27 -0500
committerJoey Hess <joey@kodama.kitenet.net>2008-02-27 16:33:27 -0500
commit7b7b98c5d4f09d4428486d954b98083c373a0617 (patch)
treeeed5efeaf330922dd6659503b5aa37379ee8920c
parent92ff3d163e8a9b34b1774dc7dbbd375dfc8937e4 (diff)
* dh_compress: Pass -n to gzip to yeild more reproducible file contents.
The time stamp information need not be contained in the .gz file since the time stamp is preserved when compressing and decompressing. Closes: #467100
-rw-r--r--debian/changelog8
-rwxr-xr-xdh_compress2
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index aaebfb8e..6db4310a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+debhelper (6.0.6) UNRELEASED; urgency=low
+
+ * dh_compress: Pass -n to gzip to yeild more reproducible file contents.
+ The time stamp information need not be contained in the .gz file since the
+ time stamp is preserved when compressing and decompressing. Closes: #467100
+
+ -- Joey Hess <joeyh@debian.org> Wed, 27 Feb 2008 16:30:16 -0500
+
debhelper (6.0.5) unstable; urgency=low
* dh_installman: Recode all man pages to utf-8 on installation.
diff --git a/dh_compress b/dh_compress
index d9758f0f..2a996776 100755
--- a/dh_compress
+++ b/dh_compress
@@ -150,7 +150,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Make executables not be anymore.
xargs(\@f,"chmod","a-x");
- xargs(\@f,"gzip","-9f");
+ xargs(\@f,"gzip","-9nf");
}
# Now change over any files we can that used to be hard links so