summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-08-05 11:00:10 -0400
committerJoey Hess <joey@kitenet.net>2011-08-05 11:00:10 -0400
commit7da05db96ef52c0f3367538c2b197341484a70c2 (patch)
tree43bcac3230662048517a66252d8a045863d88a0a
parentc7129bd1fe604d7ae2617fe1b6f516d8aee199b6 (diff)
dh: The --before --after --until and --remaining options are deprecated. Use override targets instead.
-rw-r--r--debian/changelog7
-rwxr-xr-xdh13
-rw-r--r--doc/TODO2
3 files changed, 21 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c4840bc1..b0fbe40b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (8.9.4) UNRELEASED; urgency=low
+
+ * dh: The --before --after --until and --remaining options are deprecated.
+ Use override targets instead.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 05 Aug 2011 10:58:36 -0400
+
debhelper (8.9.3) unstable; urgency=low
* dh: Remove obsolete optimisation hack that caused sequence breakage
diff --git a/dh b/dh
index bf9685d7..474cba88 100755
--- a/dh
+++ b/dh
@@ -56,18 +56,22 @@ List all available addons.
=item B<--until> I<cmd>
Run commands in the sequence until and including I<cmd>, then stop.
+(Deprecated)
=item B<--before> I<cmd>
Run commands in the sequence before I<cmd>, then stop.
+(Deprecated)
=item B<--after> I<cmd>
Run commands in the sequence that come after I<cmd>.
+(Deprecated)
=item B<--remaining>
Run all commands in the sequence that have yet to be run.
+(Deprecated)
=item B<--no-act>
@@ -322,6 +326,7 @@ init(options => {
);
inhibit_log();
set_buildflags();
+warn_deprecated();
# If make is using a jobserver, but it is not available
# to this process, clean out MAKEFLAGS. This avoids
@@ -853,6 +858,14 @@ sub rules_explicit_target {
}
+sub warn_deprecated {
+ foreach my $deprecated ('until', 'after', 'before', 'remaining') {
+ if (defined $dh{uc $deprecated}) {
+ warning("The --$deprecated option is deprecated. Use override targets instead.");
+ }
+ }
+}
+
=head1 SEE ALSO
L<debhelper(7)>
diff --git a/doc/TODO b/doc/TODO
index fa2de616..573917fa 100644
--- a/doc/TODO
+++ b/doc/TODO
@@ -21,7 +21,7 @@ Deprecated:
* delsubstvar() and the last parameter to addsubstvar that makes it remove
a string are not used in debhelper itself, but have been left in the
library in case other things use them. Deprecate and remove.
-* dh --before , --after , --until , --remaining (not formally deprecated yet)
+* dh --before , --after , --until , --remaining
* debian/compress files
* deprecate dh_gconf for dh_installgsettings (stuff should be migrating
away from gconf, and then I can just remove it -- have not added warning