summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-03-12 14:16:55 -0400
committerJoey Hess <joey@kitenet.net>2011-03-12 14:16:55 -0400
commit8f29a0726bdebcb01b6fd768fde8016fcd5dc3f4 (patch)
treea7a476e058cfb89f2309d3943cc83f4d7919fa5a
parent2bee1e2cffe4a855152cdaf9e8268b2f080e4e29 (diff)
documentation
-rw-r--r--debhelper.pod17
-rw-r--r--debian/changelog9
-rw-r--r--debian/compat2
-rwxr-xr-xdh_makeshlibs5
4 files changed, 32 insertions, 1 deletions
diff --git a/debhelper.pod b/debhelper.pod
index f541a7e..9bb06e7 100644
--- a/debhelper.pod
+++ b/debhelper.pod
@@ -503,6 +503,23 @@ none is specified.
=back
+=item v9
+
+This compatability level is still open for development; use with caution.
+
+Changes from v8 are:
+
+=over 8
+
+=item -
+
+Multiarch support. In particular, B<dh_auto_configure> passes
+multiarch directories to autoconf in --libdir and --libexecdir,
+while B<dh_makeshlibs> detects packages containing multiarch
+directories and sets a Pre-Dependency on multiarch-support is
+${misc:Pre-Depends} . A version of dpkg-dev supporting multiarch
+is required for this to work.
+
=item v8
This is the recommended mode of operation.
diff --git a/debian/changelog b/debian/changelog
index 0a51b29..b2f9b0f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,15 @@ debhelper (8.1.3) UNRELEASED; urgency=low
in some rule other than clean, perhaps to clean up an intermediate
build before a second build is run, debian/rules clean still runs it.
Closes: #615553
+ * Started work on Debhelper v9. It is still experimental, and more
+ changes may be added to that mode.
+ * Support multiarch in v9. Thanks, Steve Langasek. Closes: #617761
+ * dh_auto_configure: Support multiarch in v9 by passing multiarch
+ directories to --libdir and --libexecdir. dpkg-dev (>= 1.16.0)
+ is needed for this to be done, so packages should build-depend on it.
+ * dh_makeshlibs: Detect packages using multiarch directories and
+ make ${misc:Pre-Depends} expand to multiarch-support. Also needs
+ a new enough dpkg-dev.
-- Joey Hess <joeyh@debian.org> Sun, 27 Feb 2011 15:43:12 -0400
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/dh_makeshlibs b/dh_makeshlibs
index 896c5b3..9880211 100755
--- a/dh_makeshlibs
+++ b/dh_makeshlibs
@@ -21,6 +21,11 @@ libraries, and generates a shlibs file for the libraries it finds.
It also adds a call to ldconfig in the F<postinst> and F<postrm> scripts (in
v3 mode and above only) to any packages in which it finds shared libraries.
+In v9 mode and above, packages that support multiarch are detected, and
+a Pre-Dependency on multiarch-support is set in ${misc:Pre-Depends} ;
+you should make sure to put that token into an appropriate place in your
+debian/control file for packages supporting multiarch.
+
=head1 FILES
=over 4