summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-08-13 21:48:14 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-08-13 21:48:14 -0400
commit9973f4e4c99dc7e23d3494e27d52c27415713c86 (patch)
tree24181362a740087fdf736ad41256e2c97dd331fd
parent61a7aa8bff13509fe349392edd35cfa35640c4c1 (diff)
improve python regexps, per bzed
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm4
1 files changed, 2 insertions, 2 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 4dc2a0d9..bc6e71f7 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -145,8 +145,8 @@ sub setup_py {
# ignored by distutils/setuptools.
if ( $act eq "install" and not
( ($python =~ /^python(?:-dbg)?$/
- and $python_default =~ /^python2.[2345]$/)
- or $python =~ /^python2.[2345](?:-dbg)?$/ )) {
+ and $python_default =~ /^python2\.[2345]$/)
+ or $python =~ /^python2\.[2345](?:-dbg)?$/ )) {
$this->doit_in_sourcedir($python, "setup.py",
$act, @_, "--install-layout=deb");
}