summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-01-18 12:30:18 -0500
committerJoey Hess <joey@kodama.kitenet.net>2008-01-18 12:30:18 -0500
commita8ffa92f236e4a72287f6dc7487d0538e2e6656d (patch)
treeb51c5d0efbb47026ef46d3c014c23d0467dbb9ff
parent651159b311097089d241e2715dd18fa60da10aa3 (diff)
* dh_link: -X can be used to avoid it modifying symlinks to be compliant
with policy. Closes: #461392
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_link8
2 files changed, 14 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fbcea8c7..29419c3e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (6.0.3) UNRELEASED; urgency=low
+
+ * dh_link: -X can be used to avoid it modifying symlinks to be compliant
+ with policy. Closes: #461392
+
+ -- Joey Hess <joeyh@debian.org> Fri, 18 Jan 2008 12:29:15 -0500
+
debhelper (6.0.2) unstable; urgency=low
* Revert slightly broken refactoring of some exclude code.
diff --git a/dh_link b/dh_link
index 84e6ba35..dc396dd5 100755
--- a/dh_link
+++ b/dh_link
@@ -12,7 +12,7 @@ use Debian::Debhelper::Dh_Lib;
=head1 SYNOPSIS
-B<dh_link> [S<I<debhelper options>>] [B<-A>] [S<I<source destination ...>>]
+B<dh_link> [S<I<debhelper options>>] [B<-A>] [B<-X>I<item>] [S<I<source destination ...>>]
=head1 DESCRIPTION
@@ -54,6 +54,11 @@ conform to debian policy, and corrects them (v4 or later).
Create any links specified by command line parameters in ALL packages
acted on, not just the first.
+=item B<-Xitem>, B<--exclude=item>
+
+Do not correct symlinks that contain "item" anywhere in their filename from
+being corrected to comply with debian policy.
+
=item I<source destination ...>
Create a file named "destination" as a link to a file named "source". Do
@@ -145,6 +150,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
find(
sub {
return unless -l;
+ return if excludefile($_);
my $dir=$File::Find::dir;
$dir=~s/^\Q$tmp\E//;
my $target = readlink($_);