summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2007-11-21 19:35:16 -0500
committerJoey Hess <joey@kodama.kitenet.net>2007-11-21 19:35:16 -0500
commitb639f939432a03b322a8db30531ce25132106185 (patch)
tree94bdccf495def57b6d656271922be9445f04e1f0
parent08fe0c5daef3d144d90630b7cf6a8c83722b6c65 (diff)
* Remove execute bit from desktop files in /usr/share/applications.
Closes: #452337
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_fixperms14
2 files changed, 16 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index f632eeba..3c60778b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (5.0.62) UNRELEASED; urgency=low
+
+ * Remove execute bit from desktop files in /usr/share/applications.
+ Closes: #452337
+
+ -- Joey Hess <joeyh@debian.org> Wed, 21 Nov 2007 19:34:39 -0500
+
debhelper (5.0.61) unstable; urgency=low
* Man page fix re v4. Closes: #450608
diff --git a/dh_fixperms b/dh_fixperms
index 86a3d1b4..d9c726ca 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -23,10 +23,10 @@ dh_fixperms makes all files in usr/share/doc in the package build directory
(excluding files in the examples/ directory) be mode 644. It also changes
the permissions of all man pages to mode 644. It makes all files be owned
by root, and it removes group and other write permission from all files. It
-removes execute permissions from any libraries that have it set. It makes
-all files in bin/ directories, /usr/games/ and etc/init.d executable (since
-v4). Finally, it removes the setuid and setgid bits from all files in the
-package.
+removes execute permissions from any libraries, headers, perl modules, or
+desktop files that have it set. It makes all files in bin/ directories,
+/usr/games/ and etc/init.d executable (since v4). Finally, it removes the
+setuid and setgid bits from all files in the package.
=head1 OPTIONS
@@ -76,7 +76,11 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"2>/dev/null | xargs -0r chmod 644");
# ..and header files ..
- complex_doit("find $tmp/usr/include -type f $find_options -print0",
+ complex_doit("find $tmp/usr/include -type f $find_options -print0",
+ "2>/dev/null | xargs -0r chmod 644");
+
+ # ..and desktop files ..
+ complex_doit("find $tmp/usr/share/applications -type f $find_options -print0",
"2>/dev/null | xargs -0r chmod 644");
# .. and perl modules.