summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2010-05-27 03:00:41 -0400
committerJoey Hess <joey@kitenet.net>2010-05-27 03:00:41 -0400
commitd4bb3432196db270c979bb9a54e44e915d46f26f (patch)
treeac6a5afd2b62615445e95fc5752b51269b9165cd
parentc5693eb872c10beb7f2abf5086b79dc0095ab750 (diff)
dh_fixperms: Tighten globs used to find library .so files, avoiding incorrectly matching things like "foo.sources". Closes: #583328
-rw-r--r--debian/changelog2
-rwxr-xr-xdh_fixperms2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index c851773c..6e2aced9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,8 @@ debhelper (7.4.21) UNRELEASED; urgency=low
* dh_testversion: Removed this deprecated command.
* debian/compress files are now deprecated. Seems only one package
(genesis) still uses them.
+ * dh_fixperms: Tighten globs used to find library .so files,
+ avoiding incorrectly matching things like "foo.sources". Closes: #583328
-- Joey Hess <joeyh@debian.org> Mon, 17 May 2010 20:01:19 -0400
diff --git a/dh_fixperms b/dh_fixperms
index 10261493..893ca564 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -72,7 +72,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# ..and so are executable shared and static libraries
# (and .la files from libtool) ..
complex_doit("find $tmp -perm -5 -type f",
- "\\( -name '*.so*' -or -name '*.la' -or -name '*.a' \\) $find_options -print0",
+ "\\( -name '*.so.*' -or -name '*.so' -or -name '*.la' -or -name '*.a' \\) $find_options -print0",
"2>/dev/null | xargs -0r chmod 644");
# ..and header files ..