summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-09-17 13:36:47 -0400
committerJoey Hess <joey@kitenet.net>2012-09-17 13:36:47 -0400
commitd5c2fb4cf3d9be4bb991a8dc918fd2c6a48fe374 (patch)
tree74f1316e5ee62d5d37d36fb09ba7771346350458
parent2baf12c9e1c8c0b0cea3dc45aff3e75ea15f372a (diff)
dh_installdocs: Support having the same document id in different binary packages built from the same source. Closes: #525821 Thanks, Don Armstrong
-rw-r--r--debian/changelog3
-rwxr-xr-xdh_installdocs5
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6eed10d9..b453a27b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,6 +16,9 @@ debhelper (9.20120609) UNRELEASED; urgency=low
* Improve -X documentation. Closes: #686696
* Support installing multiple doc-base files which use the same doc-id.
(Closes: #525821)
+ * dh_installdocs: Support having the same document id in different binary
+ packages built from the same source.
+ Closes: #525821 Thanks, Don Armstrong
-- Joey Hess <joeyh@debian.org> Thu, 05 Jul 2012 08:51:07 -0600
diff --git a/dh_installdocs b/dh_installdocs
index bb09ee37..f0b5c5e2 100755
--- a/dh_installdocs
+++ b/dh_installdocs
@@ -316,13 +316,14 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# install to usr/share/doc-base/packagename-extrabits
# if the doc-base file is
# packagename.doc-base.extrabits
- if ($used_doc_ids{$doc_ids{$fn}}>1) {
+ if ($used_doc_ids{$doc_ids{$fn}} > 1) {
my $fn_no_docbase = $fn;
$fn_no_docbase =~ s/\.doc-base(?:\.(.*))?/
if (defined $1 and length $1) {"-$1"} else {''}/xe;
doit("install","-g",0,"-o",0,"-m644","-p","debian/$fn",
"$tmp/usr/share/doc-base/$fn_no_docbase");
- } else {
+ }
+ else {
doit("install","-g",0,"-o",0,"-m644","-p","debian/$fn",
"$tmp/usr/share/doc-base/$doc_ids{$fn}");
}