summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-11-20 17:38:03 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-20 17:38:03 -0500
commitef27cc7aabe55d66bdd2321d310264cba3cc4fca (patch)
treee2a38cbdfa254db8f78bba87d2bf6bc070a589aa
parent8ceb2df1b9e3368e765076b23ee0ecd4a2532a46 (diff)
Remove last vestiages of support for /usr/X11R6.
-rw-r--r--debian/changelog1
-rwxr-xr-xdh_compress7
-rwxr-xr-xdh_installman4
-rwxr-xr-xdh_installmanpages4
-rwxr-xr-xdh_installxfonts2
5 files changed, 9 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index f33da92c..e18d1071 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
debhelper (7.4.6) UNRELEASED; urgency=low
* Update --list to reflect buildsystem autoselection changes.
+ * Remove last vestiages of support for /usr/X11R6.
-- Joey Hess <joeyh@debian.org> Thu, 19 Nov 2009 14:48:03 -0500
diff --git a/dh_compress b/dh_compress
index 4e208b4f..efeca8ac 100755
--- a/dh_compress
+++ b/dh_compress
@@ -23,11 +23,10 @@ to the new files.
By default, dh_compress compresses files that debian policy mandates should
be compressed, namely all files in usr/share/info, usr/share/man,
-usr/X11R6/man, files in usr/share/doc that are larger than 4k in size,
+files in usr/share/doc that are larger than 4k in size,
(except the copyright file, .html and .css files, image files, and files
that appear to be already compressed based on their extensions), and all
-changelog files. Plus PCF fonts underneath usr/X11R6/lib/X11/fonts/ and
-usr/share/fonts/X11/
+changelog files. Plus PCF fonts underneath usr/share/fonts/X11/
=head1 FILES
@@ -114,7 +113,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
! -iname "*.svg" ! -iname "*.svgz" \\
! -name "index.sgml" \\
! -name "copyright" 2>/dev/null || true;
- find usr/X11R6/lib/X11/fonts usr/share/fonts/X11 -type f -name "*.pcf" 2>/dev/null || true;
+ find usr/share/fonts/X11 -type f -name "*.pcf" 2>/dev/null || true;
`);
}
diff --git a/dh_installman b/dh_installman
index 04c0c616..602d61b3 100755
--- a/dh_installman
+++ b/dh_installman
@@ -185,7 +185,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Now the .so conversion.
@sofiles=@sodests=();
- foreach my $dir (qw{usr/share/man usr/X11R6/man}) {
+ foreach my $dir (qw{usr/share/man}) {
if (-e "$tmp/$dir") {
find(\&find_so_man, "$tmp/$dir");
}
@@ -197,7 +197,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
}
# Now utf-8 conversion.
- foreach my $dir (qw{usr/share/man usr/X11R6/man}) {
+ foreach my $dir (qw{usr/share/man}) {
if (-e "$tmp/$dir") {
find(sub {
return if ! -f $_ || -l $_;
diff --git a/dh_installmanpages b/dh_installmanpages
index 4a5f4735..90c453ce 100755
--- a/dh_installmanpages
+++ b/dh_installmanpages
@@ -17,7 +17,7 @@ B<dh_installmanpages> [S<I<debhelper options>>] [S<I<file ...>>]
=head1 DESCRIPTION
dh_installmanpages is a debhelper program that is responsible for
-automatically installing man pages into usr/share/man/ and usr/X11R6/man/
+automatically installing man pages into usr/share/man/
in package build directories.
This is a DWIM-style program, with an interface unlike the rest of
@@ -182,7 +182,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Now the .so conversion.
@sofiles=@sodests=();
- foreach my $dir (qw{usr/share/man usr/X11R6/man}) {
+ foreach my $dir (qw{usr/share/man}) {
if (-e "$tmp/$dir") {
find(\&find_so_man, "$tmp/$dir");
}
diff --git a/dh_installxfonts b/dh_installxfonts
index 276f903c..07d6ff1d 100755
--- a/dh_installxfonts
+++ b/dh_installxfonts
@@ -51,7 +51,7 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
# Find all font directories in the package build directory.
my @fontdirs;
- foreach my $parentdir ("$tmp/usr/X11R6/lib/X11/fonts/", "$tmp/usr/share/fonts/X11/") {
+ foreach my $parentdir ("$tmp/usr/share/fonts/X11/") {
opendir(DIR, $parentdir) || next;
@fontdirs = grep { -d "$parentdir/$_" && !/^\./ } (readdir DIR);
closedir DIR;