summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-21 17:02:23 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-21 17:02:23 -0400
commitfb0d34ac16dced24297dcbc3312addee92af0857 (patch)
treeb290fa31f141e0848db8335147daa1f196d594bf
parent2a1a8bcf0321fb3c0e81031c74efaf1ab7eda3e7 (diff)
dh_fixperms: Ensure lintian overrides are mode 644. (Patch from #459548)
-rw-r--r--debian/changelog7
-rwxr-xr-xdh_fixperms7
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 12bfc24f..e275d4cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debhelper (7.2.9) UNRELEASED; urgency=low
+
+ * dh_fixperms: Ensure lintian overrides are mode 644.
+ (Patch from #459548)
+
+ -- Joey Hess <joeyh@debian.org> Tue, 21 Apr 2009 17:01:41 -0400
+
debhelper (7.2.8) unstable; urgency=low
* dh_desktop: Now a deprecated no-op, since desktop-file-utils
diff --git a/dh_fixperms b/dh_fixperms
index d9c726ca..1d4a33f3 100755
--- a/dh_fixperms
+++ b/dh_fixperms
@@ -105,6 +105,13 @@ foreach my $package (@{$dh{DOPACKAGES}}) {
"-name '*.ali' $find_options -print0",
"2>/dev/null | xargs -0r chmod uga-w");
}
+
+ # Lintian overrides should never be executable, too.
+ if (-d "$tmp/usr/share/lintian") {
+ complex_doit("find $tmp/usr/share/lintian/overrides",
+ "-type f $find_options -print0",
+ "2>/dev/null | xargs -0r chmod 644");
+ }
}
=head1 SEE ALSO