summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/cmake.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-11-18 14:28:47 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-18 14:28:47 -0500
commita81dd8b003e5152bddeccc0c92f40c003890cbdc (patch)
treee982dde2413db24966a9bf3cc7089810a388ad18 /Debian/Debhelper/Buildsystem/cmake.pm
parent84d4d291cbaf624cb9f91582a696ef6cb6a4e6ca (diff)
comment munging
Diffstat (limited to 'Debian/Debhelper/Buildsystem/cmake.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm3
1 files changed, 3 insertions, 0 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index 3eddc74f..ee90c1f9 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -18,6 +18,9 @@ sub check_auto_buildable {
my ($step)=@_;
if (-e $this->get_sourcepath("CMakeLists.txt")) {
my $ret = $this->SUPER::check_auto_buildable(@_);
+ # Existence of CMakeCache.txt indicates cmake has already
+ # been used by a prior build step, so should be used
+ # instead of the parent makefile class.
$ret++ if ($ret && -e $this->get_buildpath("CMakeCache.txt"));
return $ret > 0 ? $ret : 1;
}