summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/cmake.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-20 14:41:33 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-20 14:41:33 -0400
commit84f5388446ed30938f5df37f117543ad8b19e73d (patch)
treecf814c2017bfd890ad416e99631c10adbd65c99a /Debian/Debhelper/Buildsystem/cmake.pm
parent714e330012e0b44220312aba526b4ebaa63ef60f (diff)
use $this rather than $self
Diffstat (limited to 'Debian/Debhelper/Buildsystem/cmake.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/cmake.pm16
1 files changed, 8 insertions, 8 deletions
diff --git a/Debian/Debhelper/Buildsystem/cmake.pm b/Debian/Debhelper/Buildsystem/cmake.pm
index f40b020f..fe91503c 100644
--- a/Debian/Debhelper/Buildsystem/cmake.pm
+++ b/Debian/Debhelper/Buildsystem/cmake.pm
@@ -15,23 +15,23 @@ sub DESCRIPTION {
}
sub check_auto_buildable {
- my $self=shift;
+ my $this=shift;
my ($action)=@_;
my $ret = -e "CMakeLists.txt";
- $ret &&= $self->SUPER::check_auto_buildable(@_) if $action ne "configure";
+ $ret &&= $this->SUPER::check_auto_buildable(@_) if $action ne "configure";
return $ret;
}
sub new {
my $class=shift;
- my $self=$class->SUPER::new(@_);
+ my $this=$class->SUPER::new(@_);
# Enforce outside-source tree builds.
- $self->enforce_outside_source_building();
- return $self;
+ $this->enforce_outside_source_building();
+ return $this;
}
sub configure {
- my $self=shift;
+ my $this=shift;
my @flags;
# Standard set of cmake flags
@@ -42,8 +42,8 @@ sub configure {
push @flags, "-DCMAKE_SKIP_RPATH=ON";
push @flags, "-DCMAKE_VERBOSE_MAKEFILE=ON";
- $self->mkdir_builddir();
- $self->doit_in_builddir("cmake", $self->get_rel2builddir_path(), @flags);
+ $this->mkdir_builddir();
+ $this->doit_in_builddir("cmake", $this->get_rel2builddir_path(), @flags);
}
1;