summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/perl_makemaker.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-15 15:40:43 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-15 15:40:43 -0400
commit2ca0698b769198643fba857e50a81b880f96adeb (patch)
tree61f84441b8c7c6342e92bc9261663d5aefedcd1d /Debian/Debhelper/Buildsystem/perl_makemaker.pm
parent14d936391e07454c7936a28c512e8b42b26cd05e (diff)
removal of comments I'm satisfied with
Diffstat (limited to 'Debian/Debhelper/Buildsystem/perl_makemaker.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/perl_makemaker.pm10
1 files changed, 1 insertions, 9 deletions
diff --git a/Debian/Debhelper/Buildsystem/perl_makemaker.pm b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
index 29570166..fc86e9bd 100644
--- a/Debian/Debhelper/Buildsystem/perl_makemaker.pm
+++ b/Debian/Debhelper/Buildsystem/perl_makemaker.pm
@@ -19,15 +19,7 @@ sub check_auto_buildable {
my ($action)=@_;
# Handles configure, install; the rest - next class
- if ($action eq "install") {
- return -e "Makefile.PL";
- }
- # XXX JEH why test for configure here? If building or cleaning, and
- # a Makefile.PL exists, we know this class can handle those
- # actions -- it does so by inheriting from the makefile class.
- # XXX MDX Yes. But that's again different behaviour from current
- # (see comment in autotools.mk). Your call.
- elsif ($action eq "configure") {
+ if ($action eq "install" || $action eq "configure") {
return -e "Makefile.PL";
}
else {