summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-04-10 17:05:23 -0400
committerJoey Hess <joey@gnu.kitenet.net>2009-04-10 17:05:23 -0400
commit2b7f42f9ef70c08bb7bc138fb8b24dc993da54ac (patch)
treeb215c75636fc08ed9e2571effdbd8854e441fcd4 /Debian/Debhelper/Buildsystem/python_distutils.pm
parent776abbb23a899ebba954774c8b3740706a21f72b (diff)
code review, added comments
I went through every line of the buildsystem implementation, and added numerous comments. Search for "XXX JEH" to find them.
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm3
1 files changed, 3 insertions, 0 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 2a6df37b..2e7eacbb 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -28,6 +28,8 @@ sub get_builddir_option {
return;
}
+# XXX JEH the default for all these methods is to do nothing successfully.
+# So either this, or those default stubs, need to be removed.
sub configure_impl {
# Do nothing
1;
@@ -38,6 +40,7 @@ sub build_impl {
doit("python", "setup.py", "build", @_);
}
+# XXX JEH see anove comment
sub test_impl {
1;
}