summaryrefslogtreecommitdiff
path: root/Debian/Debhelper/Buildsystem/python_distutils.pm
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-10-22 16:07:28 -0400
committerJoey Hess <joey@kitenet.net>2012-10-22 16:07:28 -0400
commitf79ed4ddd81b299fe9b7aab55c0ef01b89989910 (patch)
tree3b9ecbca7b19607c75f9917e9deefb369941c246 /Debian/Debhelper/Buildsystem/python_distutils.pm
parent3eda9d1c88f6b9888c6255f2defdac30310af144 (diff)
adjust other fix
This is really atrocious, but IIRC the order pythons are run in matters, so the earlier mangling of @python_requested must remain, and so unmangle it here.
Diffstat (limited to 'Debian/Debhelper/Buildsystem/python_distutils.pm')
-rw-r--r--Debian/Debhelper/Buildsystem/python_distutils.pm9
1 files changed, 8 insertions, 1 deletions
diff --git a/Debian/Debhelper/Buildsystem/python_distutils.pm b/Debian/Debhelper/Buildsystem/python_distutils.pm
index 81cff3c9..fd317306 100644
--- a/Debian/Debhelper/Buildsystem/python_distutils.pm
+++ b/Debian/Debhelper/Buildsystem/python_distutils.pm
@@ -155,7 +155,14 @@ sub setup_py {
}
foreach my $python (@python_dbg, @python_requested) {
- if (-f "/usr/lib/$python/distutils/__init__.py") {
+ my $python_with_version = $python;
+ if ($python eq "python") {
+ $python_with_version = $python_default;
+ }
+ elsif ($python eq "python-dbg") {
+ $python_with_version = $python_default."-dbg";
+ }
+ if (-f "/usr/lib/$python_with_version/distutils/__init__.py") {
# To allow backports of debhelper we don't pass
# --install-layout=deb to 'setup.py install` for
# those Python versions where the option is